CVE-2016-9601

MEDIUM

Description

ghostscript before version 9.21 is vulnerable to a heap based buffer overflow that was found in the ghostscript jbig2_decode_gray_scale_image function which is used to decode halftone segments in a JBIG2 image. A document (PostScript or PDF) with an embedded, specially crafted, jbig2 image could trigger a segmentation fault in ghostscript.

References

http://git.ghostscript.com/?p=jbig2dec.git;a=commit;h=e698d5c11d27212aa1098bc5b1673a3378563092

http://www.securityfocus.com/bid/97095

https://bugs.ghostscript.com/show_bug.cgi?id=697457

https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-9601

https://security.gentoo.org/glsa/201706-24

https://www.debian.org/security/2017/dsa-3817

Details

Source: MITRE

Published: 2018-04-24

Updated: 2019-10-09

Type: CWE-119

Risk Information

CVSS v2.0

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3.0

Base Score: 5.5

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 1.8

Severity: MEDIUM