CVE-2016-7995

LOW

Description

Memory leak in the ehci_process_itd function in hw/usb/hcd-ehci.c in QEMU (aka Quick Emulator) allows local guest OS administrators to cause a denial of service (memory consumption) via a large number of crafted buffer page select (PG) indexes.

References

http://git.qemu.org/?p=qemu.git;a=commit;h=b16c129daf0fed91febbb88de23dae8271c8898a

http://lists.opensuse.org/opensuse-updates/2016-12/msg00140.html

http://www.openwall.com/lists/oss-security/2016/10/07/3

http://www.openwall.com/lists/oss-security/2016/10/08/4

http://www.securityfocus.com/bid/93454

https://lists.gnu.org/archive/html/qemu-devel/2016-09/msg06609.html

Details

Source: MITRE

Published: 2016-12-10

Updated: 2017-01-07

Type: CWE-399

Risk Information

CVSS v2.0

Base Score: 2.1

Vector: AV:L/AC:L/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 3.9

Severity: LOW

CVSS v3.0

Base Score: 6

Vector: CVSS:3.0/AV:L/AC:L/PR:H/UI:N/S:C/C:N/I:N/A:H

Impact Score: 4

Exploitability Score: 1.5

Severity: MEDIUM