CVE-2016-7462

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The Suite REST API in VMware vRealize Operations (aka vROps) 6.x before 6.4.0 allows remote authenticated users to write arbitrary content to files or rename files via a crafted DiskFileItem in a relay-request payload that is mishandled during deserialization.

References

http://www.securityfocus.com/bid/94351

http://www.securitytracker.com/id/1037297

http://www.vmware.com/security/advisories/VMSA-2016-0020.html

https://www.tenable.com/security/research/tra-2016-34

Details

Source: MITRE

Published: 2016-12-29

Updated: 2017-07-28

Type: CWE-264

Risk Information

CVSS v2

Base Score: 7.5

Vector: AV:N/AC:L/Au:S/C:N/I:P/A:C

Impact Score: 7.8

Exploitability Score: 8

Severity: HIGH

CVSS v3

Base Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:L/A:H

Impact Score: 4.7

Exploitability Score: 3.1

Severity: HIGH

Tenable Plugins

View all (1 total)

IDNameProductFamilySeverity
95441VMware vRealize Operations Manager ver 6.x < 6.40 Suite API CollectorHttpRelayController RelayRequest Object DiskFileItem Deserialization DoSNessusCGI abuses
high