CVE-2016-6793

critical
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The DiskFileItem class in Apache Wicket 6.x before 6.25.0 and 1.5.x before 1.5.17 allows remote attackers to cause a denial of service (infinite loop) and write to, move, and delete files with the permissions of DiskFileItem, and if running on a Java VM before 1.3.1, execute arbitrary code via a crafted serialized Java object.

References

http://www.openwall.com/lists/oss-security/2016/12/31/1

http://www.securityfocus.com/archive/1/539975/100/0/threaded

http://www.securityfocus.com/bid/95168

http://www.securitytracker.com/id/1037541

https://wicket.apache.org/news/2016/12/31/cve-2016-6793.html

https://www.tenable.com/security/research/tra-2016-23

Details

Source: MITRE

Published: 2017-07-17

Updated: 2019-05-06

Type: CWE-502

Risk Information

CVSS v2

Base Score: 6.4

Vector: AV:N/AC:L/Au:N/C:N/I:P/A:P

Impact Score: 4.9

Exploitability Score: 10

Severity: MEDIUM

CVSS v3

Base Score: 9.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H

Impact Score: 5.2

Exploitability Score: 3.9

Severity: CRITICAL