CVE-2016-6508

MEDIUM

Description

epan/dissectors/packet-rlc.c in the RLC dissector in Wireshark 1.12.x before 1.12.13 and 2.x before 2.0.5 uses an incorrect integer data type, which allows remote attackers to cause a denial of service (large loop) via a crafted packet.

References

http://openwall.com/lists/oss-security/2016/07/28/3

http://www.debian.org/security/2016/dsa-3648

http://www.securitytracker.com/id/1036480

http://www.wireshark.org/security/wnpa-sec-2016-44.html

https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=12660

https://code.wireshark.org/review/gitweb?p=wireshark.git;a=commit;h=6cf9616df68a4db7e436bb77392586ff9ad84feb

Details

Source: MITRE

Published: 2016-08-06

Updated: 2016-11-28

Type: CWE-399

Risk Information

CVSS v2.0

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3.0

Base Score: 5.9

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 2.2

Severity: MEDIUM