CVE-2016-6333

MEDIUM

Description

Cross-site scripting (XSS) vulnerability in the CSS user subpage preview feature in MediaWiki before 1.23.15, 1.26.x before 1.26.4, and 1.27.x before 1.27.1 allows remote attackers to inject arbitrary web script or HTML via the edit box in Special:MyPage/common.css.

References

http://www.securityfocus.com/bid/98053

https://bugzilla.redhat.com/show_bug.cgi?id=1369613

https://lists.wikimedia.org/pipermail/mediawiki-announce/2016-August/000195.html

https://phabricator.wikimedia.org/T133147

Details

Source: MITRE

Published: 2017-04-20

Updated: 2017-04-29

Type: CWE-79

Risk Information

CVSS v2.0

Base Score: 4.3

Vector: (AV:N/AC:M/Au:N/C:N/I:P/A:N)

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3.0

Base Score: 6.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Impact Score: 2.7

Exploitability Score: 2.8

Severity: MEDIUM