CVE-2016-5829

HIGH

Description

Multiple heap-based buffer overflows in the hiddev_ioctl_usage function in drivers/hid/usbhid/hiddev.c in the Linux kernel through 4.6.3 allow local users to cause a denial of service or possibly have unspecified other impact via a crafted (1) HIDIOCGUSAGES or (2) HIDIOCSUSAGES ioctl call.

References

http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=93a2001bdfd5376c3dc2158653034c20392d15c5

http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00000.html

http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00007.html

http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00027.html

http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00044.html

http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00048.html

http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00049.html

http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00050.html

http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00051.html

http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00052.html

http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00053.html

http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00054.html

http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00055.html

http://rhn.redhat.com/errata/RHSA-2016-2006.html

http://rhn.redhat.com/errata/RHSA-2016-2574.html

http://rhn.redhat.com/errata/RHSA-2016-2584.html

http://www.debian.org/security/2016/dsa-3616

http://www.openwall.com/lists/oss-security/2016/06/26/2

http://www.oracle.com/technetwork/topics/security/linuxbulletinoct2016-3090545.html

http://www.oracle.com/technetwork/topics/security/ovmbulletinoct2016-3090547.html

http://www.securityfocus.com/bid/91450

http://www.ubuntu.com/usn/USN-3070-1

http://www.ubuntu.com/usn/USN-3070-2

http://www.ubuntu.com/usn/USN-3070-3

http://www.ubuntu.com/usn/USN-3070-4

http://www.ubuntu.com/usn/USN-3071-1

http://www.ubuntu.com/usn/USN-3071-2

http://www.ubuntu.com/usn/USN-3072-1

http://www.ubuntu.com/usn/USN-3072-2

https://github.com/torvalds/linux/commit/93a2001bdfd5376c3dc2158653034c20392d15c5

Details

Source: MITRE

Published: 2016-06-27

Updated: 2018-01-05

Type: CWE-119

Risk Information

CVSS v2.0

Base Score: 7.2

Vector: AV:L/AC:L/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 3.9

Severity: HIGH

CVSS v3.0

Base Score: 7.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 1.8

Severity: HIGH

Tenable Plugins

View all (38 total)

IDNameProductFamilySeverity
125100EulerOS Virtualization 3.0.1.0 : kernel (EulerOS-SA-2019-1494)NessusHuawei Local Security Checks
high
124988EulerOS Virtualization for ARM 64 3.0.1.0 : kernel (EulerOS-SA-2019-1535)NessusHuawei Local Security Checks
high
99163OracleVM 3.3 : Unbreakable / etc (OVMSA-2017-0057) (Dirty COW)NessusOracleVM Local Security Checks
critical
97445F5 Networks BIG-IP : Linux kernel vulnerability (K28056114)NessusF5 Networks Local Security Checks
high
97205SUSE SLES12 Security Update : kernel (SUSE-SU-2017:0471-1)NessusSuSE Local Security Checks
high
96903SUSE SLES11 Security Update : kernel (SUSE-SU-2017:0333-1)NessusSuSE Local Security Checks
critical
95841Scientific Linux Security Update : kernel on SL7.x x86_64 (20161103)NessusScientific Linux Local Security Checks
critical
95321CentOS 7 : kernel (CESA-2016:2574)NessusCentOS Local Security Checks
critical
94929OracleVM 3.2 : Unbreakable / etc (OVMSA-2016-0158) (Dirty COW)NessusOracleVM Local Security Checks
high
94697Oracle Linux 7 : kernel (ELSA-2016-2574)NessusOracle Linux Local Security Checks
critical
94547RHEL 7 : kernel-rt (RHSA-2016:2584)NessusRed Hat Local Security Checks
critical
94537RHEL 7 : kernel (RHSA-2016:2574)NessusRed Hat Local Security Checks
critical
93908OracleVM 3.3 : Unbreakable / etc (OVMSA-2016-0139)NessusOracleVM Local Security Checks
high
93907OracleVM 3.4 : Unbreakable / etc (OVMSA-2016-0138)NessusOracleVM Local Security Checks
high
93906Oracle Linux 6 / 7 : Unbreakable Enterprise kernel (ELSA-2016-3625)NessusOracle Linux Local Security Checks
high
93905Oracle Linux 5 / 6 : Unbreakable Enterprise kernel (ELSA-2016-3624)NessusOracle Linux Local Security Checks
high
93904Oracle Linux 6 / 7 : Unbreakable Enterprise kernel (ELSA-2016-3623)NessusOracle Linux Local Security Checks
high
93892Scientific Linux Security Update : kernel on SL6.x i386/x86_64 (20161004)NessusScientific Linux Local Security Checks
high
93867CentOS 6 : kernel (CESA-2016:2006)NessusCentOS Local Security Checks
high
93858RHEL 6 : kernel (RHSA-2016:2006)NessusRed Hat Local Security Checks
high
93857Oracle Linux 6 : kernel (ELSA-2016-2006)NessusOracle Linux Local Security Checks
high
93370SUSE SLES11 Security Update : kernel (SUSE-SU-2016:2245-1)NessusSuSE Local Security Checks
critical
93321Debian DLA-609-1 : linux security updateNessusDebian Local Security Checks
high
93299SUSE SLED12 / SLES12 Security Update : kernel (SUSE-SU-2016:2105-1)NessusSuSE Local Security Checks
high
93284SUSE SLES11 Security Update : kernel (SUSE-SU-2016:2018-1)NessusSuSE Local Security Checks
high
93243Ubuntu 14.04 LTS : linux-lts-xenial vulnerabilities (USN-3070-4)NessusUbuntu Local Security Checks
high
93242Ubuntu 16.04 LTS : linux-snapdragon vulnerabilities (USN-3070-3)NessusUbuntu Local Security Checks
high
93241Ubuntu 16.04 LTS : linux-raspi2 vulnerabilities (USN-3070-2)NessusUbuntu Local Security Checks
high
93220Ubuntu 12.04 LTS : linux vulnerabilities (USN-3072-1)NessusUbuntu Local Security Checks
high
93219Ubuntu 12.04 LTS : linux-lts-trusty vulnerabilities (USN-3071-2)NessusUbuntu Local Security Checks
high
93218Ubuntu 14.04 LTS : linux vulnerabilities (USN-3071-1)NessusUbuntu Local Security Checks
high
93217Ubuntu 16.04 LTS : linux vulnerabilities (USN-3070-1)NessusUbuntu Local Security Checks
high
93216openSUSE Security Update : the Linux Kernel (openSUSE-2016-1029)NessusSuSE Local Security Checks
high
93104openSUSE Security Update : the Linux Kernel (openSUSE-2016-1015)NessusSuSE Local Security Checks
critical
92446Fedora 24 : kernel (2016-9a16b2e14e)NessusFedora Local Security Checks
high
92308openSUSE Security Update : the Linux Kernel (openSUSE-2016-869)NessusSuSE Local Security Checks
high
92256Fedora 23 : kernel (2016-73a733f4d9)NessusFedora Local Security Checks
high
91927Debian DSA-3616-1 : linux - security updateNessusDebian Local Security Checks
high