CVE-2016-5687

HIGH

Description

The VerticalFilter function in the DDS coder in ImageMagick before 6.9.4-3 and 7.x before 7.0.1-4 allows remote attackers to have unspecified impact via a crafted DDS file, which triggers an out-of-bounds read.

References

http://www.openwall.com/lists/oss-security/2016/06/14/5

http://www.openwall.com/lists/oss-security/2016/06/17/3

http://www.oracle.com/technetwork/topics/security/bulletinjul2016-3090568.html

http://www.securityfocus.com/bid/91283

https://blog.fuzzing-project.org/46-Various-invalid-memory-reads-in-ImageMagick-WPG,-DDS,-DCM.html

Details

Source: MITRE

Published: 2016-12-13

Updated: 2016-12-16

Type: CWE-125

Risk Information

CVSS v2.0

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 3.9

Severity: CRITICAL

Tenable Plugins

View all (11 total)

IDNameProductFamilySeverity
135519EulerOS 2.0 SP3 : ImageMagick (EulerOS-SA-2020-1390)NessusHuawei Local Security Checks
high
131846EulerOS 2.0 SP2 : ImageMagick (EulerOS-SA-2019-2354)NessusHuawei Local Security Checks
high
129127EulerOS 2.0 SP5 : ImageMagick (EulerOS-SA-2019-1970)NessusHuawei Local Security Checks
high
95453SUSE SLES11 Security Update : ImageMagick (SUSE-SU-2016:2964-1)NessusSuSE Local Security Checks
high
95053Ubuntu 12.04 LTS / 14.04 LTS / 16.04 LTS / 16.10 : imagemagick vulnerabilities (USN-3131-1)NessusUbuntu Local Security Checks
high
93179SUSE SLED12 / SLES12 Security Update : ImageMagick (SUSE-SU-2016:1784-1)NessusSuSE Local Security Checks
high
93178SUSE SLES11 Security Update : ImageMagick (SUSE-SU-2016:1782-1)NessusSuSE Local Security Checks
high
93115Debian DSA-3652-1 : imagemagick - security updateNessusDebian Local Security Checks
high
92487openSUSE Security Update : ImageMagick (openSUSE-2016-883)NessusSuSE Local Security Checks
high
91967openSUSE Security Update : ImageMagick (openSUSE-2016-840)NessusSuSE Local Security Checks
high
91818ImageMagick 6.x < 6.9.4-3 / 7.x < 7.0.1-4 Multiple VulnerabilitiesNessusWindows
high