CVE-2016-5359

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

epan/dissectors/packet-wbxml.c in the WBXML dissector in Wireshark 1.12.x before 1.12.12 mishandles offsets, which allows remote attackers to cause a denial of service (integer overflow and infinite loop) via a crafted packet.

References

http://www.debian.org/security/2016/dsa-3615

http://www.openwall.com/lists/oss-security/2016/06/09/3

http://www.securityfocus.com/bid/91140

https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=12408

https://github.com/wireshark/wireshark/commit/b8e0d416898bb975a02c1b55883342edc5b4c9c0

https://www.wireshark.org/security/wnpa-sec-2016-38.html

Details

Source: MITRE

Published: 2016-08-07

Updated: 2016-11-28

Type: CWE-119

Risk Information

CVSS v2

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 5.9

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 2.2

Severity: MEDIUM

Tenable Plugins

View all (6 total)

IDNameProductFamilySeverity
131579EulerOS 2.0 SP2 : wireshark (EulerOS-SA-2019-2425)NessusHuawei Local Security Checks
high
93863SUSE SLED12 / SLES12 Security Update : wireshark (SUSE-SU-2016:2453-1)NessusSuSE Local Security Checks
high
93342SUSE SLES11 Security Update : wireshark (SUSE-SU-2016:2212-1)NessusSuSE Local Security Checks
high
91926Debian DSA-3615-1 : wireshark - security updateNessusDebian Local Security Checks
high
91905Debian DLA-538-1 : wireshark security updateNessusDebian Local Security Checks
high
91820Wireshark 1.12.x < 1.12.12 Multiple DoSNessusWindows
medium