CVE-2016-5244

MEDIUM

Description

The rds_inc_info_copy function in net/rds/recv.c in the Linux kernel through 4.6.3 does not initialize a certain structure member, which allows remote attackers to obtain sensitive information from kernel stack memory by reading an RDS message.

References

http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=4116def2337991b39919f3b448326e21c40e0dbb

http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00044.html

http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00052.html

http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00054.html

http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00000.html

http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00007.html

http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00044.html

http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00055.html

http://www.debian.org/security/2016/dsa-3607

http://www.openwall.com/lists/oss-security/2016/06/03/5

http://www.oracle.com/technetwork/security-advisory/cpuoct2018-4428296.html

http://www.securityfocus.com/bid/91021

http://www.securitytracker.com/id/1041895

http://www.ubuntu.com/usn/USN-3070-1

http://www.ubuntu.com/usn/USN-3070-2

http://www.ubuntu.com/usn/USN-3070-3

http://www.ubuntu.com/usn/USN-3070-4

http://www.ubuntu.com/usn/USN-3071-1

http://www.ubuntu.com/usn/USN-3071-2

http://www.ubuntu.com/usn/USN-3072-1

http://www.ubuntu.com/usn/USN-3072-2

https://bugzilla.redhat.com/show_bug.cgi?id=1343337

https://github.com/torvalds/linux/commit/4116def2337991b39919f3b448326e21c40e0dbb

https://patchwork.ozlabs.org/patch/629110/

Details

Source: MITRE

Published: 2016-06-27

Updated: 2019-04-22

Type: CWE-200

Risk Information

CVSS v2.0

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Impact Score: 3.6

Exploitability Score: 3.9

Severity: HIGH

Tenable Plugins

View all (26 total)

IDNameProductFamilySeverity
137128OracleVM 3.4 : Unbreakable / etc (OVMSA-2020-0019)NessusOracleVM Local Security Checks
high
136388Oracle Linux 6 / 7 : Unbreakable Enterprise kernel (ELSA-2020-5670)NessusOracle Linux Local Security Checks
high
133632Oracle Linux 7 : Unbreakable Enterprise kernel (ELSA-2020-5533)NessusOracle Linux Local Security Checks
high
124990EulerOS Virtualization for ARM 64 3.0.1.0 : kernel (EulerOS-SA-2019-1537)NessusHuawei Local Security Checks
high
118190Oracle Solaris Critical Patch Update : oct2018_SRU11_4_1_4_0NessusSolaris Local Security Checks
medium
96903SUSE SLES11 Security Update : kernel (SUSE-SU-2017:0333-1)NessusSuSE Local Security Checks
critical
93370SUSE SLES11 Security Update : kernel (SUSE-SU-2016:2245-1)NessusSuSE Local Security Checks
critical
93299SUSE SLED12 / SLES12 Security Update : kernel (SUSE-SU-2016:2105-1)NessusSuSE Local Security Checks
high
93243Ubuntu 14.04 LTS : linux-lts-xenial vulnerabilities (USN-3070-4)NessusUbuntu Local Security Checks
high
93242Ubuntu 16.04 LTS : linux-snapdragon vulnerabilities (USN-3070-3)NessusUbuntu Local Security Checks
high
93241Ubuntu 16.04 LTS : linux-raspi2 vulnerabilities (USN-3070-2)NessusUbuntu Local Security Checks
high
93220Ubuntu 12.04 LTS : linux vulnerabilities (USN-3072-1)NessusUbuntu Local Security Checks
high
93219Ubuntu 12.04 LTS : linux-lts-trusty vulnerabilities (USN-3071-2)NessusUbuntu Local Security Checks
high
93218Ubuntu 14.04 LTS : linux vulnerabilities (USN-3071-1)NessusUbuntu Local Security Checks
high
93217Ubuntu 16.04 LTS : linux vulnerabilities (USN-3070-1)NessusUbuntu Local Security Checks
high
93216openSUSE Security Update : the Linux Kernel (openSUSE-2016-1029)NessusSuSE Local Security Checks
high
93165SUSE SLED12 / SLES12 Security Update : kernel (SUSE-SU-2016:1690-1)NessusSuSE Local Security Checks
high
93164SUSE SLES11 Security Update : kernel (SUSE-SU-2016:1672-1)NessusSuSE Local Security Checks
high
93104openSUSE Security Update : the Linux Kernel (openSUSE-2016-1015)NessusSuSE Local Security Checks
critical
92661Amazon Linux AMI : kernel (ALAS-2016-726)NessusAmazon Linux Local Security Checks
medium
92184Fedora 24 : kernel (2016-e0f3fcd7df)NessusFedora Local Security Checks
medium
92121Fedora 23 : kernel (2016-80edb9d511)NessusFedora Local Security Checks
medium
92085Fedora 22 : kernel (2016-3daf782dfa)NessusFedora Local Security Checks
medium
91886Debian DSA-3607-1 : linux - security updateNessusDebian Local Security Checks
critical
91736openSUSE Security Update : the Linux Kernel (openSUSE-2016-753)NessusSuSE Local Security Checks
critical
91687Debian DLA-516-1 : linux security updateNessusDebian Local Security Checks
critical