CVE-2016-5240

MEDIUM
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The DrawDashPolygon function in magick/render.c in GraphicsMagick before 1.3.24 and the SVG renderer in ImageMagick allow remote attackers to cause a denial of service (infinite loop) by converting a circularly defined SVG file.

References

http://hg.graphicsmagick.org/hg/GraphicsMagick?cmd=changeset;node=ddc999ec896c

http://www.debian.org/security/2016/dsa-3746

http://www.graphicsmagick.org/ChangeLog-2016.html

http://www.openwall.com/lists/oss-security/2016/05/01/4

http://www.openwall.com/lists/oss-security/2016/05/01/6

http://www.openwall.com/lists/oss-security/2016/06/02/14

http://www.oracle.com/technetwork/topics/security/linuxbulletinapr2016-2952096.html

http://www.securityfocus.com/bid/89348

https://access.redhat.com/errata/RHSA-2016:1237

Details

Source: MITRE

Published: 2017-02-27

Updated: 2018-05-18

Type: CWE-20

Risk Information

CVSS v2

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 5.5

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 1.8

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:graphicsmagick:graphicsmagick:*:*:*:*:*:*:*:* versions up to 1.3.23 (inclusive)

Tenable Plugins

View all (10 total)

IDNameProductFamilySeverity
99792EulerOS 2.0 SP1 : ImageMagick (EulerOS-SA-2016-1029)NessusHuawei Local Security Checks
critical
96103Debian DSA-3746-1 : graphicsmagick - security update (ImageTragick)NessusDebian Local Security Checks
critical
92981openSUSE Security Update : GraphicsMagick (openSUSE-2016-984)NessusSuSE Local Security Checks
critical
92665Debian DLA-547-2 : graphicsmagick regression updateNessusDebian Local Security Checks
medium
91945openSUSE Security Update : GraphicsMagick (openSUSE-2016-825)NessusSuSE Local Security Checks
critical
91768Amazon Linux AMI : ImageMagick (ALAS-2016-716)NessusAmazon Linux Local Security Checks
critical
91712Scientific Linux Security Update : ImageMagick on SL6.x, SL7.x i386/x86_64 (20160617)NessusScientific Linux Local Security Checks
critical
91642RHEL 6 / 7 : ImageMagick (RHSA-2016:1237)NessusRed Hat Local Security Checks
critical
91641Oracle Linux 6 / 7 : ImageMagick (ELSA-2016-1237)NessusOracle Linux Local Security Checks
critical
91636CentOS 6 / 7 : ImageMagick (CESA-2016:1237)NessusCentOS Local Security Checks
critical