CVE-2016-5114

MEDIUM

Description

sapi/fpm/fpm/fpm_log.c in PHP before 5.5.31, 5.6.x before 5.6.17, and 7.x before 7.0.2 misinterprets the semantics of the snprintf return value, which allows attackers to obtain sensitive information from process memory or cause a denial of service (out-of-bounds read and buffer overflow) via a long string, as demonstrated by a long URI in a configuration with custom REQUEST_URI logging.

References

http://github.com/php/php-src/commit/2721a0148649e07ed74468f097a28899741eb58f?w=1

http://php.net/ChangeLog-5.php

http://php.net/ChangeLog-7.php

http://rhn.redhat.com/errata/RHSA-2016-2750.html

http://www.openwall.com/lists/oss-security/2016/05/29/1

http://www.search-lab.hu/about-us/news/111-some-unusual-vulnerabilities-in-the-php-engine

https://bugs.php.net/bug.php?id=70755

https://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05240731

Details

Source: MITRE

Published: 2016-08-07

Updated: 2018-01-05

Type: CWE-119

Risk Information

CVSS v2.0

Base Score: 6.4

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:P

Impact Score: 4.9

Exploitability Score: 10

Severity: MEDIUM

CVSS v3.0

Base Score: 9.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Impact Score: 5.2

Exploitability Score: 3.9

Severity: CRITICAL

Tenable Plugins

View all (12 total)

IDNameProductFamilySeverity
129236EulerOS 2.0 SP3 : php (EulerOS-SA-2019-2043)NessusHuawei Local Security Checks
high
128931EulerOS Virtualization for ARM 64 3.0.2.0 : php (EulerOS-SA-2019-1928)NessusHuawei Local Security Checks
high
128917EulerOS 2.0 SP2 : php (EulerOS-SA-2019-1865)NessusHuawei Local Security Checks
high
128087EulerOS 2.0 SP5 : php (EulerOS-SA-2019-1795)NessusHuawei Local Security Checks
high
98873PHP 5.6.x < 5.6.17 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
medium
93568Debian DLA-628-1 : php5 security updateNessusDebian Local Security Checks
high
93161SUSE SLES11 Security Update : php53 (SUSE-SU-2016:1638-1) (BACKRONYM)NessusSuSE Local Security Checks
critical
92699Ubuntu 12.04 LTS / 14.04 LTS / 16.04 LTS : php5, php7.0 vulnerabilities (USN-3045-1) (httpoxy)NessusUbuntu Local Security Checks
high
91665SUSE SLES11 Security Update : php53 (SUSE-SU-2016:1581-1)NessusSuSE Local Security Checks
critical
91585openSUSE Security Update : php5 (openSUSE-2016-703)NessusSuSE Local Security Checks
high
88680PHP 7.x < 7.0.2 Multiple VulnerabilitiesNessusCGI abuses
high
88679PHP prior to 5.5.x < 5.5.31 / 5.6.x < 5.6.17 Multiple VulnerabilitiesNessusCGI abuses
medium