CVE-2016-4070

HIGH
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

** DISPUTED ** Integer overflow in the php_raw_url_encode function in ext/standard/url.c in PHP before 5.5.34, 5.6.x before 5.6.20, and 7.x before 7.0.5 allows remote attackers to cause a denial of service (application crash) via a long string to the rawurlencode function. NOTE: the vendor says "Not sure if this qualifies as security issue (probably not)."

References

http://lists.apple.com/archives/security-announce/2016/May/msg00004.html

http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00031.html

http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00033.html

http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00056.html

http://rhn.redhat.com/errata/RHSA-2016-2750.html

http://www.debian.org/security/2016/dsa-3560

http://www.openwall.com/lists/oss-security/2016/04/24/1

http://www.php.net/ChangeLog-5.php

http://www.php.net/ChangeLog-7.php

http://www.securityfocus.com/bid/85801

http://www.ubuntu.com/usn/USN-2952-1

http://www.ubuntu.com/usn/USN-2952-2

https://bugs.php.net/bug.php?id=71798

https://git.php.net/?p=php-src.git;a=commit;h=95433e8e339dbb6b5d5541473c1661db6ba2c451

https://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05240731

https://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05320149

https://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05390722

https://support.apple.com/HT206567

Details

Source: MITRE

Published: 2016-05-20

Updated: 2018-01-05

Type: CWE-189

Risk Information

CVSS v2

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

CVSS v3

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 3.9

Severity: HIGH

Tenable Plugins

View all (23 total)

IDNameProductFamilySeverity
137966EulerOS Virtualization 3.0.6.0 : php (EulerOS-SA-2020-1747)NessusHuawei Local Security Checks
critical
132184EulerOS 2.0 SP3 : php (EulerOS-SA-2019-2649)NessusHuawei Local Security Checks
critical
131592EulerOS 2.0 SP2 : php (EulerOS-SA-2019-2438)NessusHuawei Local Security Checks
critical
130683EulerOS 2.0 SP5 : php (EulerOS-SA-2019-2221)NessusHuawei Local Security Checks
critical
98851PHP 7.0.x < 7.0.5 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
98810PHP 5.6.x < 5.6.20 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
119976SUSE SLES12 Security Update : php5 (SUSE-SU-2016:1277-1)NessusSuSE Local Security Checks
critical
95965F5 Networks BIG-IP : PHP vulnerability (K42065024)NessusF5 Networks Local Security Checks
high
94654HP System Management Homepage < 7.6 Multiple Vulnerabilities (HPSBMU03653) (httpoxy)NessusWeb Servers
high
93161SUSE SLES11 Security Update : php53 (SUSE-SU-2016:1638-1) (BACKRONYM)NessusSuSE Local Security Checks
critical
9392Mac OS X 10.11.x < 10.11.5 Multiple VulnerabilitiesNessus Network MonitorOperating System Detection
high
91665SUSE SLES11 Security Update : php53 (SUSE-SU-2016:1581-1)NessusSuSE Local Security Checks
critical
91397Debian DLA-499-1 : php5 security updateNessusDebian Local Security Checks
critical
91320Ubuntu 12.04 LTS / 14.04 LTS / 15.10 / 16.04 LTS : php5, php7.0 vulnerabilities (USN-2984-1)NessusUbuntu Local Security Checks
critical
91290openSUSE Security Update : php5 (openSUSE-2016-626)NessusSuSE Local Security Checks
critical
91247SUSE SLES11 Security Update : php53 (SUSE-SU-2016:1310-1)NessusSuSE Local Security Checks
critical
91228Mac OS X 10.11.x < 10.11.5 Multiple VulnerabilitiesNessusMacOS X Local Security Checks
high
91071openSUSE Security Update : php5 (openSUSE-2016-576)NessusSuSE Local Security Checks
critical
90867Amazon Linux AMI : php56 / php55 (ALAS-2016-698)NessusAmazon Linux Local Security Checks
critical
90768Debian DSA-3560-1 : php5 - security updateNessusDebian Local Security Checks
critical
90362PHP 7.0.x < 7.0.5 Multiple VulnerabilitiesNessusCGI abuses
critical
90361PHP 5.6.x < 5.6.20 Multiple VulnerabilitiesNessusCGI abuses
critical
90360PHP 5.5.x < 5.5.34 Multiple VulnerabilitiesNessusCGI abuses
critical