CVE-2016-2554

critical
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Stack-based buffer overflow in ext/phar/tar.c in PHP before 5.5.32, 5.6.x before 5.6.18, and 7.x before 7.0.3 allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted TAR archive.

References

http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00052.html

http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00056.html

http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00058.html

http://php.net/ChangeLog-5.php

http://php.net/ChangeLog-7.php

http://rhn.redhat.com/errata/RHSA-2016-2750.html

http://www.ubuntu.com/usn/USN-2952-1

http://www.ubuntu.com/usn/USN-2952-2

https://bugs.php.net/bug.php?id=71488

https://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05240731

Details

Source: MITRE

Published: 2016-05-16

Updated: 2018-01-05

Type: CWE-119

Risk Information

CVSS v2

Base Score: 10

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 10

Severity: HIGH

CVSS v3

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 3.9

Severity: CRITICAL

Tenable Plugins

View all (20 total)

IDNameProductFamilySeverity
137966EulerOS Virtualization 3.0.6.0 : php (EulerOS-SA-2020-1747)NessusHuawei Local Security Checks
critical
132184EulerOS 2.0 SP3 : php (EulerOS-SA-2019-2649)NessusHuawei Local Security Checks
critical
131592EulerOS 2.0 SP2 : php (EulerOS-SA-2019-2438)NessusHuawei Local Security Checks
critical
130683EulerOS 2.0 SP5 : php (EulerOS-SA-2019-2221)NessusHuawei Local Security Checks
critical
98848PHP 7.0.x < 7.0.3 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
high
98807PHP 5.6.x < 5.6.18 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
high
119975SUSE SLES12 Security Update : php5 (SUSE-SU-2016:1166-1)NessusSuSE Local Security Checks
critical
97052Debian DLA-818-1 : php5 security updateNessusDebian Local Security Checks
critical
93161SUSE SLES11 Security Update : php53 (SUSE-SU-2016:1638-1) (BACKRONYM)NessusSuSE Local Security Checks
critical
91665SUSE SLES11 Security Update : php53 (SUSE-SU-2016:1581-1)NessusSuSE Local Security Checks
critical
90825Ubuntu 15.10 : php5 regression (USN-2952-2)NessusUbuntu Local Security Checks
critical
90782openSUSE Security Update : php5 (openSUSE-2016-517)NessusSuSE Local Security Checks
critical
90757SUSE SLES11 Security Update : php53 (SUSE-SU-2016:1145-1)NessusSuSE Local Security Checks
critical
90677Ubuntu 12.04 LTS / 14.04 LTS / 15.10 : php5 vulnerabilities (USN-2952-1)NessusUbuntu Local Security Checks
critical
90513Amazon Linux AMI : php56 / php55 (ALAS-2016-685)NessusAmazon Linux Local Security Checks
critical
89856openSUSE Security Update : php5 (openSUSE-2016-323)NessusSuSE Local Security Checks
critical
88695PHP 7.0.x < 7.0.3 Multiple VulnerabilitiesNessusCGI abuses
critical
88694PHP 5.6.x < 5.6.18 Multiple VulnerabilitiesNessusCGI abuses
critical
88693PHP 5.5.x < 5.5.32 Multiple VulnerabilitiesNessusCGI abuses
critical
88671FreeBSD : php -- multiple vulnerabilities (85eb4e46-cf16-11e5-840f-485d605f4717)NessusFreeBSD Local Security Checks
critical