CVE-2016-2337

critical
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Type confusion exists in _cancel_eval Ruby's TclTkIp class method. Attacker passing different type of object than String as "retval" argument can cause arbitrary code execution.

References

http://www.securityfocus.com/bid/91233

http://www.talosintelligence.com/reports/TALOS-2016-0031/

https://lists.debian.org/debian-lts-announce/2018/08/msg00028.html

https://security.gentoo.org/glsa/201710-18

Details

Source: MITRE

Published: 2017-01-06

Updated: 2018-08-28

Risk Information

CVSS v2

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

CVSS v3

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 3.9

Severity: CRITICAL

Tenable Plugins

View all (6 total)

IDNameProductFamilySeverity
125569EulerOS Virtualization for ARM 64 3.0.2.0 : ruby (EulerOS-SA-2019-1617)NessusHuawei Local Security Checks
critical
112167Debian DLA-1480-1 : ruby2.1 security updateNessusDebian Local Security Checks
critical
103911GLSA-201710-18 : Ruby: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical
101974Ubuntu 14.04 LTS / 16.04 LTS / 17.04 : ruby1.9.1, ruby2.0, ruby2.3 vulnerabilities (USN-3365-1)NessusUbuntu Local Security Checks
critical
99896EulerOS 2.0 SP2 : ruby (EulerOS-SA-2017-1051)NessusHuawei Local Security Checks
critical
99895EulerOS 2.0 SP1 : ruby (EulerOS-SA-2017-1050)NessusHuawei Local Security Checks
critical