CVE-2016-1626

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The opj_pi_update_decode_poc function in pi.c in OpenJPEG, as used in PDFium in Google Chrome before 48.0.2564.109, miscalculates a certain layer index value, which allows remote attackers to cause a denial of service (out-of-bounds read) via a crafted PDF document.

References

http://googlechromereleases.blogspot.com/2016/02/stable-channel-update_9.html

http://lists.opensuse.org/opensuse-updates/2016-02/msg00104.html

http://lists.opensuse.org/opensuse-updates/2016-02/msg00119.html

http://rhn.redhat.com/errata/RHSA-2016-0241.html

http://www.debian.org/security/2016/dsa-3486

http://www.securityfocus.com/bid/83125

http://www.securitytracker.com/id/1035183

http://www.zerodayinitiative.com/advisories/ZDI-16-171

https://code.google.com/p/chromium/issues/detail?id=571480

https://codereview.chromium.org/1583233008

https://security.gentoo.org/glsa/201603-09

https://security.gentoo.org/glsa/201710-26

Details

Source: MITRE

Published: 2016-02-14

Updated: 2018-10-30

Type: CWE-119

Risk Information

CVSS v2

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:P/I:N/A:N

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 4.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N

Impact Score: 1.4

Exploitability Score: 2.8

Severity: MEDIUM

Tenable Plugins

View all (10 total)

IDNameProductFamilySeverity
104069GLSA-201710-26 : OpenJPEG: Multiple vulnerabilitiesNessusGentoo Local Security Checks
high
89902GLSA-201603-09 : Chromium: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical
88879openSUSE Security Update : Chromium (openSUSE-2016-238)NessusSuSE Local Security Checks
high
88869Debian DSA-3486-1 : chromium-browser - security updateNessusDebian Local Security Checks
critical
9083Google Chrome < 48.0.2564.109 Multiple VulnerabilitiesNessus Network MonitorWeb Clients
high
88826openSUSE Security Update : Chromium (openSUSE-2016-221)NessusSuSE Local Security Checks
high
88794RHEL 6 : chromium-browser (RHSA-2016:0241)NessusRed Hat Local Security Checks
high
88682Google Chrome < 48.0.2564.109 Multiple Vulnerabilities (Mac OS X)NessusMacOS X Local Security Checks
high
88681Google Chrome < 48.0.2564.109 Multiple VulnerabilitiesNessusWindows
high
88667FreeBSD : chromium -- multiple vulnerabilities (36034227-cf81-11e5-9c2b-00262d5ed8ee)NessusFreeBSD Local Security Checks
high