CVE-2016-10167

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The gdImageCreateFromGd2Ctx function in gd_gd2.c in the GD Graphics Library (aka libgd) before 2.2.4 allows remote attackers to cause a denial of service (application crash) via a crafted image file.

References

http://libgd.github.io/release-2.2.4.html

http://www.debian.org/security/2017/dsa-3777

http://www.openwall.com/lists/oss-security/2017/01/26/1

http://www.openwall.com/lists/oss-security/2017/01/28/6

http://www.securityfocus.com/bid/95869

http://www.securitytracker.com/id/1037659

https://access.redhat.com/errata/RHSA-2017:3221

https://access.redhat.com/errata/RHSA-2018:1296

https://github.com/libgd/libgd/commit/fe9ed49dafa993e3af96b6a5a589efeea9bfb36f

https://www.tenable.com/security/tns-2017-04

Details

Source: MITRE

Published: 2017-03-15

Updated: 2018-05-04

Type: CWE-20

Risk Information

CVSS v2

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 5.5

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 1.8

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:libgd:libgd:*:*:*:*:*:*:*:* versions up to 2.2.3 (inclusive)

Tenable Plugins

View all (36 total)

IDNameProductFamilySeverity
135626EulerOS Virtualization 3.0.2.2 : gd (EulerOS-SA-2020-1464)NessusHuawei Local Security Checks
high
135513EulerOS 2.0 SP3 : gd (EulerOS-SA-2020-1384)NessusHuawei Local Security Checks
high
131674EulerOS 2.0 SP2 : gd (EulerOS-SA-2019-2521)NessusHuawei Local Security Checks
critical
130858EulerOS 2.0 SP5 : gd (EulerOS-SA-2019-2149)NessusHuawei Local Security Checks
high
127174NewStart CGSL CORE 5.04 / MAIN 5.04 : php Multiple Vulnerabilities (NS-SA-2019-0019)NessusNewStart CGSL Local Security Checks
high
124905EulerOS Virtualization for ARM 64 3.0.1.0 : php (EulerOS-SA-2019-1402)NessusHuawei Local Security Checks
critical
98856PHP 7.1.x < 7.1.1 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
98839PHP 7.0.x < 7.0.15 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
98821PHP 5.6.x < 5.6.30 Multiple DoSWeb Application ScanningComponent Vulnerability
critical
119994SUSE SLES12 Security Update : php5 (SUSE-SU-2017:0556-1)NessusSuSE Local Security Checks
critical
119993SUSE SLES12 Security Update : php7 (SUSE-SU-2017:0534-1)NessusSuSE Local Security Checks
critical
109432Slackware 13.0 / 13.1 / 13.37 / 14.0 / 14.1 / 14.2 / current : libwmf (SSA:2018-120-01)NessusSlackware Local Security Checks
high
104920EulerOS 2.0 SP2 : php (EulerOS-SA-2017-1302)NessusHuawei Local Security Checks
high
104919EulerOS 2.0 SP1 : php (EulerOS-SA-2017-1301)NessusHuawei Local Security Checks
high
104674Virtuozzo 7 : php / php-bcmath / php-cli / php-common / php-dba / etc (VZLSA-2017-3221)NessusVirtuozzo Local Security Checks
high
104624Scientific Linux Security Update : php on SL7.x x86_64 (20171115)NessusScientific Linux Local Security Checks
high
104618Oracle Linux 7 : php (ELSA-2017-3221)NessusOracle Linux Local Security Checks
high
104584CentOS 7 : php (CESA-2017:3221)NessusCentOS Local Security Checks
high
104568RHEL 7 : php (RHSA-2017:3221)NessusRed Hat Local Security Checks
high
101790Slackware 14.2 / current : gd (SSA:2017-199-02)NessusSlackware Local Security Checks
critical
101050Tenable SecurityCenter PHP < 5.6.30 Multiple Vulnerabilities (TNS-2017-04)NessusMisc.
critical
99039Amazon Linux AMI : php70 (ALAS-2017-812)NessusAmazon Linux Local Security Checks
critical
99035Amazon Linux AMI : php56 (ALAS-2017-808)NessusAmazon Linux Local Security Checks
critical
97726Tenable SecurityCenter 5.x < 5.4.3 Multiple Vulnerabilities (TNS-2017-04) (httpoxy)NessusMisc.
medium
97563openSUSE Security Update : php7 (openSUSE-2017-304)NessusSuSE Local Security Checks
critical
97468Ubuntu 12.04 LTS / 14.04 LTS / 16.04 LTS / 16.10 : libgd2 vulnerabilities (USN-3213-1)NessusUbuntu Local Security Checks
critical
97431SUSE SLES11 Security Update : php53 (SUSE-SU-2017:0568-1)NessusSuSE Local Security Checks
critical
97369openSUSE Security Update : gd (openSUSE-2017-289)NessusSuSE Local Security Checks
critical
97203SUSE SLED12 / SLES12 Security Update : gd (SUSE-SU-2017:0468-1)NessusSuSE Local Security Checks
critical
97186SUSE SLES11 Security Update : gd (SUSE-SU-2017:0459-1)NessusSuSE Local Security Checks
high
97103Slackware 14.0 / 14.1 / 14.2 / current : php (SSA:2017-041-03)NessusSlackware Local Security Checks
critical
96912Debian DSA-3777-1 : libgd2 - security updateNessusDebian Local Security Checks
critical
96839Debian DLA-804-1 : libgd2 security updateNessusDebian Local Security Checks
high
96801PHP 7.1.x < 7.1.1 Multiple VulnerabilitiesNessusCGI abuses
critical
96800PHP 7.0.x < 7.0.15 Multiple VulnerabilitiesNessusCGI abuses
critical
96799PHP 5.6.x < 5.6.30 Multiple DoSNessusCGI abuses
critical