CVE-2016-10166

critical
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Integer underflow in the _gdContributionsAlloc function in gd_interpolation.c in the GD Graphics Library (aka libgd) before 2.2.4 allows remote attackers to have unspecified impact via vectors related to decrementing the u variable.

References

http://libgd.github.io/release-2.2.4.html

http://www.debian.org/security/2017/dsa-3777

http://www.openwall.com/lists/oss-security/2017/01/26/1

http://www.openwall.com/lists/oss-security/2017/01/28/6

http://www.securityfocus.com/bid/95869

https://access.redhat.com/errata/RHSA-2019:2519

https://access.redhat.com/errata/RHSA-2019:3299

https://github.com/libgd/libgd/commit/60bfb401ad5a4a8ae995dcd36372fe15c71e1a35

Details

Source: MITRE

Published: 2017-03-15

Updated: 2017-11-04

Type: CWE-191

Risk Information

CVSS v2

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

CVSS v3

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 3.9

Severity: CRITICAL

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:libgd:libgd:*:*:*:*:*:*:*:* versions up to 2.2.3 (inclusive)

Tenable Plugins

View all (19 total)

IDNameProductFamilySeverity
98245PHP 5.6.x < 5.6.40 Multiple vulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
98244PHP 7.1.x < 7.1.26 Multiple vulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
98243PHP 7.2.x < 7.2.14 Multiple vulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
98242PHP 7.3.x < 7.3.1 Multiple vulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
121602PHP 5.6.x < 5.6.40 Multiple vulnerabilities.NessusCGI abuses
critical
121510PHP 7.1.x < 7.1.26 Multiple vulnerabilities.NessusCGI abuses
critical
121475PHP 7.3.x < 7.3.1 Multiple vulnerabilities.NessusCGI abuses
critical
121353PHP 7.2.x < 7.2.14 Multiple vulnerabilities.NessusCGI abuses
critical
119994SUSE SLES12 Security Update : php5 (SUSE-SU-2017:0556-1)NessusSuSE Local Security Checks
critical
119993SUSE SLES12 Security Update : php7 (SUSE-SU-2017:0534-1)NessusSuSE Local Security Checks
critical
101790Slackware 14.2 / current : gd (SSA:2017-199-02)NessusSlackware Local Security Checks
critical
97706Fedora 24 : libwmf (2017-9a5b89363f)NessusFedora Local Security Checks
critical
97563openSUSE Security Update : php7 (openSUSE-2017-304)NessusSuSE Local Security Checks
critical
97468Ubuntu 12.04 LTS / 14.04 LTS / 16.04 LTS / 16.10 : libgd2 vulnerabilities (USN-3213-1)NessusUbuntu Local Security Checks
critical
97431SUSE SLES11 Security Update : php53 (SUSE-SU-2017:0568-1)NessusSuSE Local Security Checks
critical
97369openSUSE Security Update : gd (openSUSE-2017-289)NessusSuSE Local Security Checks
critical
97203SUSE SLED12 / SLES12 Security Update : gd (SUSE-SU-2017:0468-1)NessusSuSE Local Security Checks
critical
97181Fedora 25 : libwmf (2017-f787c35494)NessusFedora Local Security Checks
critical
96912Debian DSA-3777-1 : libgd2 - security updateNessusDebian Local Security Checks
critical