CVE-2016-10162

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The php_wddx_pop_element function in ext/wddx/wddx.c in PHP 7.0.x before 7.0.15 and 7.1.x before 7.1.1 allows remote attackers to cause a denial of service (NULL pointer dereference and application crash) via an inapplicable class name in a wddxPacket XML document, leading to mishandling in a wddx_deserialize call.

References

http://php.net/ChangeLog-7.php

http://www.securityfocus.com/bid/95668

http://www.securitytracker.com/id/1037659

https://access.redhat.com/errata/RHSA-2018:1296

https://bugs.php.net/bug.php?id=73831

https://github.com/php/php-src/commit/8d2539fa0faf3f63e1d1e7635347c5b9e777d47b

Details

Source: MITRE

Published: 2017-01-24

Updated: 2018-05-04

Type: CWE-476

Risk Information

CVSS v2

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

CVSS v3

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 3.9

Severity: HIGH

Tenable Plugins

View all (10 total)

IDNameProductFamilySeverity
98856PHP 7.1.x < 7.1.1 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
98839PHP 7.0.x < 7.0.15 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
119993SUSE SLES12 Security Update : php7 (SUSE-SU-2017:0534-1)NessusSuSE Local Security Checks
critical
99039Amazon Linux AMI : php70 (ALAS-2017-812)NessusAmazon Linux Local Security Checks
critical
97563openSUSE Security Update : php7 (openSUSE-2017-304)NessusSuSE Local Security Checks
critical
97521Ubuntu 16.04 LTS / 16.10 : php7.0 regression (USN-3211-2)NessusUbuntu Local Security Checks
critical
97384Ubuntu 16.04 LTS / 16.10 : php7.0 vulnerabilities (USN-3211-1)NessusUbuntu Local Security Checks
critical
9938PHP 7.0.x < 7.0.15 / 7.1.x < 7.1.1 Multiple VulnerabilitiesNessus Network MonitorWeb Servers
critical
96801PHP 7.1.x < 7.1.1 Multiple VulnerabilitiesNessusCGI abuses
critical
96800PHP 7.0.x < 7.0.15 Multiple VulnerabilitiesNessusCGI abuses
critical