CVE-2016-1016

HIGH

Description

Use-after-free vulnerability in the Transform object implementation in Adobe Flash Player before 18.0.0.343 and 19.x through 21.x before 21.0.0.213 on Windows and OS X and before 11.2.202.616 on Linux allows attackers to execute arbitrary code via a flash.geom.Matrix callback, a different vulnerability than CVE-2016-1011, CVE-2016-1013, CVE-2016-1017, and CVE-2016-1031.

References

http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00044.html

http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00045.html

http://rhn.redhat.com/errata/RHSA-2016-0610.html

http://www.securityfocus.com/bid/85926

http://www.securitytracker.com/id/1035509

http://www.zerodayinitiative.com/advisories/ZDI-16-226/

https://docs.microsoft.com/en-us/security-updates/securitybulletins/2016/ms16-050

https://helpx.adobe.com/security/products/flash-player/apsb16-10.html

Details

Source: MITRE

Published: 2016-04-09

Updated: 2018-10-12

Risk Information

CVSS v2.0

Base Score: 9.3

Vector: (AV:N/AC:M/Au:N/C:C/I:C/A:C)

Impact Score: 10

Exploitability Score: 8.6

Severity: HIGH

CVSS v3.0

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 2.8

Severity: HIGH