CVE-2016-0774

MEDIUM

Description

The (1) pipe_read and (2) pipe_write implementations in fs/pipe.c in a certain Linux kernel backport in the linux package before 3.2.73-2+deb7u3 on Debian wheezy and the kernel package before 3.10.0-229.26.2 on Red Hat Enterprise Linux (RHEL) 7.1 do not properly consider the side effects of failed __copy_to_user_inatomic and __copy_from_user_inatomic calls, which allows local users to cause a denial of service (system crash) or possibly gain privileges via a crafted application, aka an "I/O vector array overrun." NOTE: this vulnerability exists because of an incorrect fix for CVE-2015-1805.

References

http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00025.html

http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00026.html

http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00027.html

http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00028.html

http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00029.html

http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00030.html

http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00031.html

http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00032.html

http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00033.html

http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00034.html

http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00036.html

http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00037.html

http://rhn.redhat.com/errata/RHSA-2016-0494.html

http://rhn.redhat.com/errata/RHSA-2016-0617.html

http://source.android.com/security/bulletin/2016-05-01.html

http://www.debian.org/security/2016/dsa-3503

http://www.oracle.com/technetwork/topics/security/linuxbulletinapr2016-2952096.html

http://www.securityfocus.com/bid/84126

http://www.ubuntu.com/usn/USN-2967-1

http://www.ubuntu.com/usn/USN-2967-2

http://www.ubuntu.com/usn/USN-2968-1

http://www.ubuntu.com/usn/USN-2968-2

https://bugzilla.redhat.com/show_bug.cgi?id=1303961

https://security-tracker.debian.org/tracker/CVE-2016-0774

Details

Source: MITRE

Published: 2016-04-27

Updated: 2016-12-03

Type: CWE-20

Risk Information

CVSS v2.0

Base Score: 5.6

Vector: (AV:L/AC:L/Au:N/C:P/I:N/A:C)

Impact Score: 7.8

Exploitability Score: 3.9

Severity: MEDIUM

CVSS v3.0

Base Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H

Impact Score: 4.2

Exploitability Score: 2.5

Severity: MEDIUM