CVE-2015-8900

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The ReadHDRImage function in coders/hdr.c in ImageMagick 6.x and 7.x allows remote attackers to cause a denial of service (infinite loop) via a crafted HDR file.

References

http://trac.imagemagick.org/changeset/17845

http://trac.imagemagick.org/changeset/17846

http://www.imagemagick.org/discourse-server/viewtopic.php?f=3&t=26929

http://www.openwall.com/lists/oss-security/2015/02/26/13

http://www.openwall.com/lists/oss-security/2016/06/06/2

https://bugzilla.redhat.com/show_bug.cgi?id=1195260

https://github.com/ImageMagick/ImageMagick/commit/97aa7d7cfd2027f6ba7ce42caf8b798541b9cdc6

Details

Source: MITRE

Published: 2017-02-27

Updated: 2020-07-31

Type: CWE-835

Risk Information

CVSS v2

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 5.5

Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 1.8

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:imagemagick:imagemagick:*:*:*:*:*:*:*:* versions from 6.0 to 6.9.3-10 (inclusive)

cpe:2.3:a:imagemagick:imagemagick:*:*:*:*:*:*:*:* versions from 7.0.1-0 to 7.0.5-0 (inclusive)

Tenable Plugins

View all (7 total)

IDNameProductFamilySeverity
135519EulerOS 2.0 SP3 : ImageMagick (EulerOS-SA-2020-1390)NessusHuawei Local Security Checks
critical
131846EulerOS 2.0 SP2 : ImageMagick (EulerOS-SA-2019-2354)NessusHuawei Local Security Checks
critical
100480Debian DLA-960-1 : imagemagick security updateNessusDebian Local Security Checks
critical
95053Ubuntu 12.04 LTS / 14.04 LTS / 16.04 LTS / 16.10 : imagemagick vulnerabilities (USN-3131-1)NessusUbuntu Local Security Checks
critical
93179SUSE SLED12 / SLES12 Security Update : ImageMagick (SUSE-SU-2016:1784-1)NessusSuSE Local Security Checks
critical
92487openSUSE Security Update : ImageMagick (openSUSE-2016-883)NessusSuSE Local Security Checks
critical
91967openSUSE Security Update : ImageMagick (openSUSE-2016-840)NessusSuSE Local Security Checks
critical