CVE-2015-8876

HIGH

Description

Zend/zend_exceptions.c in PHP before 5.4.44, 5.5.x before 5.5.28, and 5.6.x before 5.6.12 does not validate certain Exception objects, which allows remote attackers to cause a denial of service (NULL pointer dereference and application crash) or trigger unintended method execution via crafted serialized data.

References

http://rhn.redhat.com/errata/RHSA-2016-2750.html

http://www.php.net/ChangeLog-5.php

https://bugs.php.net/bug.php?id=70121

Details

Source: MITRE

Published: 2016-05-22

Updated: 2019-02-14

Risk Information

CVSS v2.0

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 3.9

Severity: CRITICAL

Tenable Plugins

View all (7 total)

IDNameProductFamilySeverity
119993SUSE SLES12 Security Update : php7 (SUSE-SU-2017:0534-1)NessusSuSE Local Security Checks
high
97563openSUSE Security Update : php7 (openSUSE-2017-304)NessusSuSE Local Security Checks
high
93160SUSE SLED12 / SLES12 Security Update : php5 (SUSE-SU-2016:1633-1)NessusSuSE Local Security Checks
high
92699Ubuntu 12.04 LTS / 14.04 LTS / 16.04 LTS : php5, php7.0 vulnerabilities (USN-3045-1) (httpoxy)NessusUbuntu Local Security Checks
high
91869openSUSE Security Update : php5 (openSUSE-2016-776)NessusSuSE Local Security Checks
high
91585openSUSE Security Update : php5 (openSUSE-2016-703)NessusSuSE Local Security Checks
high
85299PHP 5.5.x < 5.5.28 Multiple VulnerabilitiesNessusCGI abuses
high