CVE-2015-7969

MEDIUM

Description

Multiple memory leaks in Xen 4.0 through 4.6.x allow local guest administrators or domains with certain permission to cause a denial of service (memory consumption) via a large number of "teardowns" of domains with the vcpu pointer array allocated using the (1) XEN_DOMCTL_max_vcpus hypercall or the xenoprofile state vcpu pointer array allocated using the (2) XENOPROF_get_buffer or (3) XENOPROF_set_passive hypercall.

References

http://lists.fedoraproject.org/pipermail/package-announce/2015-November/171082.html

http://lists.fedoraproject.org/pipermail/package-announce/2015-November/171185.html

http://lists.fedoraproject.org/pipermail/package-announce/2015-November/171249.html

http://lists.opensuse.org/opensuse-updates/2015-11/msg00063.html

http://support.citrix.com/article/CTX202404

http://www.debian.org/security/2015/dsa-3414

http://www.securityfocus.com/bid/77364

http://www.securitytracker.com/id/1034033

http://xenbits.xen.org/xsa/advisory-149.html

http://xenbits.xen.org/xsa/advisory-151.html

https://security.gentoo.org/glsa/201604-03

Details

Source: MITRE

Published: 2015-10-30

Updated: 2018-10-30

Type: CWE-399

Risk Information

CVSS v2.0

Base Score: 4.9

Vector: AV:L/AC:L/Au:N/C:N/I:N/A:C

Impact Score: 6.9

Exploitability Score: 3.9

Severity: MEDIUM

Tenable Plugins

View all (25 total)

IDNameProductFamilySeverity
140019OracleVM 3.4 : xen (OVMSA-2020-0039) (Bunker Buster) (Foreshadow) (MDSUM/RIDL) (MFBDS/RIDL/ZombieLoad) (MLPDS/RIDL) (MSBDS/Fallout) (Meltdown) (POODLE) (Spectre)NessusOracleVM Local Security Checks
critical
111992OracleVM 3.4 : xen (OVMSA-2018-0248) (Bunker Buster) (Foreshadow) (Meltdown) (POODLE) (Spectre)NessusOracleVM Local Security Checks
critical
91756OracleVM 3.2 : xen (OVMSA-2016-0081)NessusOracleVM Local Security Checks
high
91198Debian DLA-479-1 : xen security updateNessusDebian Local Security Checks
medium
90380GLSA-201604-03 : Xen: Multiple vulnerabilities (Venom)NessusGentoo Local Security Checks
high
89359Fedora 23 : xen-4.5.1-14.fc23 (2015-a931b02be2)NessusFedora Local Security Checks
high
89278Fedora 22 : xen-4.5.1-14.fc22 (2015-6f6b79efe2)NessusFedora Local Security Checks
high
89177Fedora 21 : xen-4.4.3-7.fc21 (2015-242be2c240)NessusFedora Local Security Checks
high
87650SUSE SLED11 / SLES11 Security Update : xen (SUSE-SU-2015:2338-1)NessusSuSE Local Security Checks
high
87591SUSE SLED12 / SLES12 Security Update : xen (SUSE-SU-2015:2328-1)NessusSuSE Local Security Checks
high
87590SUSE SLED11 / SLES11 Security Update : xen (SUSE-SU-2015:2326-1)NessusSuSE Local Security Checks
high
87528SUSE SLES11 Security Update : xen (SUSE-SU-2015:2306-1)NessusSuSE Local Security Checks
medium
87288Debian DSA-3414-1 : xen - security updateNessusDebian Local Security Checks
medium
86961openSUSE Security Update : xen (openSUSE-2015-730)NessusSuSE Local Security Checks
high
86909openSUSE Security Update : xen (openSUSE-2015-750)NessusSuSE Local Security Checks
high
86865SUSE SLES11 Security Update : xen (SUSE-SU-2015:1952-1)NessusSuSE Local Security Checks
high
86863openSUSE Security Update : xen (openSUSE-2015-729)NessusSuSE Local Security Checks
high
86842FreeBSD : xen-kernel -- leak of main per-domain vcpu pointer array (fc1f8795-881d-11e5-ab94-002590263bf5)NessusFreeBSD Local Security Checks
medium
86840FreeBSD : xen-kernel -- leak of per-domain profiling-related vcpu pointer array (e3792855-881f-11e5-ab94-002590263bf5)NessusFreeBSD Local Security Checks
medium
86802OracleVM 3.2 : xen (OVMSA-2015-0143)NessusOracleVM Local Security Checks
high
86756SUSE SLED12 / SLES12 Security Update : xen (SUSE-SU-2015:1908-1)NessusSuSE Local Security Checks
high
86753SUSE SLED11 / SLES11 Security Update : xen (SUSE-SU-2015:1894-1)NessusSuSE Local Security Checks
high
86704SUSE SLED11 / SLES11 Security Update : xen (SUSE-SU-2015:1853-1)NessusSuSE Local Security Checks
high
86670OracleVM 3.2 : xen (OVMSA-2015-0142)NessusOracleVM Local Security Checks
high
86669OracleVM 3.3 : xen (OVMSA-2015-0141)NessusOracleVM Local Security Checks
high