CVE-2015-7199

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The (1) AddWeightedPathSegLists and (2) SVGPathSegListSMILType::Interpolate functions in Mozilla Firefox before 42.0 and Firefox ESR 38.x before 38.4 lack status checking, which allows remote attackers to cause a denial of service (memory corruption) or possibly have unspecified other impact via a crafted SVG document.

References

http://lists.opensuse.org/opensuse-security-announce/2015-11/msg00013.html

http://lists.opensuse.org/opensuse-security-announce/2015-11/msg00015.html

http://lists.opensuse.org/opensuse-security-announce/2015-11/msg00020.html

http://lists.opensuse.org/opensuse-security-announce/2015-11/msg00021.html

http://lists.opensuse.org/opensuse-security-announce/2015-11/msg00025.html

http://lists.opensuse.org/opensuse-updates/2015-12/msg00037.html

http://lists.opensuse.org/opensuse-updates/2015-12/msg00049.html

http://rhn.redhat.com/errata/RHSA-2015-1982.html

http://rhn.redhat.com/errata/RHSA-2015-2519.html

http://www.debian.org/security/2015/dsa-3393

http://www.debian.org/security/2015/dsa-3410

http://www.mozilla.org/security/announce/2015/mfsa2015-131.html

http://www.oracle.com/technetwork/topics/security/bulletinapr2016-2952098.html

http://www.oracle.com/technetwork/topics/security/linuxbulletinoct2015-2719645.html

http://www.securityfocus.com/bid/77411

http://www.securitytracker.com/id/1034069

http://www.ubuntu.com/usn/USN-2785-1

http://www.ubuntu.com/usn/USN-2819-1

https://bugzilla.mozilla.org/show_bug.cgi?id=1204061

https://security.gentoo.org/glsa/201512-10

Details

Source: MITRE

Published: 2015-11-05

Updated: 2016-12-07

Type: CWE-119

Risk Information

CVSS v2

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

Tenable Plugins

View all (28 total)

IDNameProductFamilySeverity
9151Mozilla Thunderbird < 38.4 Multiple VulnerabilitiesNessus Network MonitorSMTP Clients
high
87710GLSA-201512-10 : Mozilla Products: Multiple vulnerabilities (Bar Mitzvah) (Logjam)NessusGentoo Local Security Checks
critical
87441openSUSE Security Update : Mozilla Thunderbird (openSUSE-2015-885)NessusSuSE Local Security Checks
critical
87390openSUSE Security Update : MozillaThunderbird (openSUSE-2015-877)NessusSuSE Local Security Checks
critical
9018Mozilla Firefox < 42.0 Multiple VulnerabilitiesNessus Network MonitorWeb Clients
critical
87168Ubuntu 12.04 LTS / 14.04 LTS / 15.04 / 15.10 : thunderbird vulnerabilities (USN-2819-1)NessusUbuntu Local Security Checks
critical
87164Debian DSA-3410-1 : icedove - security updateNessusDebian Local Security Checks
critical
87110Mozilla Thunderbird < 38.4 Multiple VulnerabilitiesNessusWindows
high
87109Mozilla Thunderbird < 38.4 Multiple Vulnerabilities (Mac OS X)NessusMacOS X Local Security Checks
high
87103Scientific Linux Security Update : thunderbird on SL5.x, SL6.x, SL7.x i386/x86_64 (20151126)NessusScientific Linux Local Security Checks
high
87100RHEL 5 / 6 / 7 : thunderbird (RHSA-2015:2519)NessusRed Hat Local Security Checks
high
87097Oracle Linux 6 / 7 : thunderbird (ELSA-2015-2519)NessusOracle Linux Local Security Checks
high
87067CentOS 5 / 6 / 7 : thunderbird (CESA-2015:2519)NessusCentOS Local Security Checks
high
87063SUSE SLES10 Security Update : Mozilla Firefox (SUSE-SU-2015:2081-1)NessusSuSE Local Security Checks
critical
86955FreeBSD : mozilla -- multiple vulnerabilities (9d04936c-75f1-4a2c-9ade-4c1708be5df9)NessusFreeBSD Local Security Checks
critical
86870SUSE SLED11 / SLES11 Security Update : MozillaFirefox, mozilla-nspr, mozilla-nss (SUSE-SU-2015:1981-1)NessusSuSE Local Security Checks
critical
86868SUSE SLES11 Security Update : MozillaFirefox, mozilla-nspr, mozilla-nss (SUSE-SU-2015:1978-1)NessusSuSE Local Security Checks
critical
86808SUSE SLED12 / SLES12 Security Update : MozillaFirefox, mozilla-nspr, mozilla-nss (SUSE-SU-2015:1926-1)NessusSuSE Local Security Checks
critical
86807openSUSE Security Update : MozillaFirefox / mozilla-nspr / mozilla-nss / etc (openSUSE-2015-718)NessusSuSE Local Security Checks
critical
86764Firefox < 42 Multiple VulnerabilitiesNessusWindows
high
86763Firefox ESR < 38.4 Multiple VulnerabilitiesNessusWindows
high
86762Firefox < 42 Multiple Vulnerabilities (Mac OS X)NessusMacOS X Local Security Checks
high
86761Firefox ESR < 38.4 Multiple Vulnerabilities (Mac OS X)NessusMacOS X Local Security Checks
high
86758Ubuntu 12.04 LTS / 14.04 LTS / 15.04 / 15.10 : firefox vulnerabilities (USN-2785-1)NessusUbuntu Local Security Checks
critical
86746RHEL 5 / 6 / 7 : firefox (RHSA-2015:1982)NessusRed Hat Local Security Checks
high
86743Oracle Linux 5 / 6 / 7 : firefox (ELSA-2015-1982)NessusOracle Linux Local Security Checks
high
86728Debian DSA-3393-1 : iceweasel - security updateNessusDebian Local Security Checks
critical
86726CentOS 5 / 6 / 7 : firefox (CESA-2015:1982)NessusCentOS Local Security Checks
high