CVE-2015-6525

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Multiple integer overflows in the evbuffer API in Libevent 2.0.x before 2.0.22 and 2.1.x before 2.1.5-beta allow context-dependent attackers to cause a denial of service or possibly have other unspecified impact via "insanely large inputs" to the (1) evbuffer_add, (2) evbuffer_prepend, (3) evbuffer_expand, (4) exbuffer_reserve_space, or (5) evbuffer_read function, which triggers a heap-based buffer overflow or an infinite loop. NOTE: this identifier was SPLIT from CVE-2014-6272 per ADT3 due to different affected versions.

References

http://archives.seul.org/libevent/users/Jan-2015/msg00010.html

http://www.debian.org/security/2015/dsa-3119

Details

Source: MITRE

Published: 2015-08-24

Updated: 2015-08-26

Type: CWE-189

Risk Information

CVSS v2

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

Tenable Plugins

View all (3 total)

IDNameProductFamilySeverity
131668EulerOS 2.0 SP2 : libevent (EulerOS-SA-2019-2515)NessusHuawei Local Security Checks
high
131027Amazon Linux 2 : libevent (ALAS-2019-1359)NessusAmazon Linux Local Security Checks
high
80393Debian DSA-3119-1 : libevent - security updateNessusDebian Local Security Checks
high