CVE-2015-5784

HIGH

Description

runner in Install.framework in the Install Framework Legacy component in Apple OS X before 10.10.5 does not properly drop privileges, which allows attackers to execute arbitrary code in a privileged context via a crafted app.

References

http://lists.apple.com/archives/security-announce/2015/Aug/msg00001.html

http://www.securityfocus.com/bid/76340

http://www.securitytracker.com/id/1033276

https://support.apple.com/kb/HT205031

https://www.exploit-db.com/exploits/38137/

Details

Source: MITRE

Published: 2015-08-17

Updated: 2017-09-21

Type: CWE-264

Risk Information

CVSS v2.0

Base Score: 9.3

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 8.6

Severity: HIGH

Vulnerable Software

Configuration 1

OR

cpe:2.3:o:apple:mac_os_x:*:*:*:*:*:*:*:* versions up to 10.10.4 (inclusive)

Tenable Plugins

View all (2 total)

IDNameProductFamilySeverity
8981Mac OS X < 10.10.5 Multiple VulnerabilitiesNessus Network MonitorOperating System Detection
high
85408Mac OS X 10.10.x < 10.10.5 Multiple VulnerabilitiesNessusMacOS X Local Security Checks
high