CVE-2015-5754

HIGH

Description

Race condition in runner in Install.framework in the Install Framework Legacy component in Apple OS X before 10.10.5 allows attackers to execute arbitrary code in a privileged context via a crafted app that leverages incorrect privilege dropping associated with a locking error.

References

http://lists.apple.com/archives/security-announce/2015/Aug/msg00001.html

http://packetstormsecurity.com/files/133550/OS-X-Suid-Privilege-Escalation.html

http://www.securityfocus.com/bid/76340

http://www.securitytracker.com/id/1033276

https://support.apple.com/kb/HT205031

https://www.exploit-db.com/exploits/38136/

Details

Source: MITRE

Published: 2015-08-17

Updated: 2017-09-21

Type: CWE-362

Risk Information

CVSS v2.0

Base Score: 9.3

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 8.6

Severity: HIGH