CVE-2015-4652

MEDIUM

Description

epan/dissectors/packet-gsm_a_dtap.c in the GSM DTAP dissector in Wireshark 1.12.x before 1.12.6 does not properly validate digit characters, which allows remote attackers to cause a denial of service (application crash) via a crafted packet, related to the de_emerg_num_list and de_bcd_num functions.

References

http://lists.opensuse.org/opensuse-updates/2015-07/msg00020.html

http://www.debian.org/security/2015/dsa-3294

http://www.securityfocus.com/bid/75316

http://www.securitytracker.com/id/1032662

http://www.wireshark.org/security/wnpa-sec-2015-20.html

https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=11201

https://code.wireshark.org/review/gitweb?p=wireshark.git;a=commit;h=d93be95fc0e7011e8b4ade9171e7e66146063296

https://security.gentoo.org/glsa/201510-03

Details

Source: MITRE

Published: 2015-07-22

Updated: 2017-07-01

Type: CWE-20

Risk Information

CVSS v2.0

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM