CVE-2015-4601

CRITICAL
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

PHP before 5.6.7 might allow remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via an unexpected data type, related to "type confusion" issues in (1) ext/soap/php_encoding.c, (2) ext/soap/php_http.c, and (3) ext/soap/soap.c, a different issue than CVE-2015-4600.

References

http://git.php.net/?p=php-src.git;a=commit;h=0c136a2abd49298b66acb0cad504f0f972f5bfe8

http://php.net/ChangeLog-5.php

http://rhn.redhat.com/errata/RHSA-2015-1135.html

http://rhn.redhat.com/errata/RHSA-2015-1218.html

http://www.openwall.com/lists/oss-security/2015/06/16/12

http://www.oracle.com/technetwork/topics/security/linuxbulletinjan2016-2867209.html

http://www.securityfocus.com/bid/75246

http://www.securitytracker.com/id/1032709

Details

Source: MITRE

Published: 2016-05-16

Updated: 2018-01-05

Risk Information

CVSS v2

Base Score: 10

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 10

Severity: HIGH

CVSS v3

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 3.9

Severity: CRITICAL

Tenable Plugins

View all (20 total)

IDNameProductFamilySeverity
98831PHP 5.6.x < 5.6.8 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
119968SUSE SLES12 Security Update : php5 (SUSE-SU-2015:1253-1)NessusSuSE Local Security Checks
critical
93161SUSE SLES11 Security Update : php53 (SUSE-SU-2016:1638-1) (BACKRONYM)NessusSuSE Local Security Checks
critical
88811F5 Networks BIG-IP : Multiple PHP vulnerabilities (K17061)NessusF5 Networks Local Security Checks
critical
85808Debian DLA-307-1 : php5 security updateNessusDebian Local Security Checks
critical
84897SUSE SLES11 Security Update : PHP (SUSE-SU-2015:1265-1)NessusSuSE Local Security Checks
critical
84661Scientific Linux Security Update : php on SL6.x i386/x86_64 (20150709)NessusScientific Linux Local Security Checks
critical
84660RHEL 6 : php (RHSA-2015:1218)NessusRed Hat Local Security Checks
critical
84659Oracle Linux 6 : php (ELSA-2015-1218)NessusOracle Linux Local Security Checks
critical
84648CentOS 6 : php (CESA-2015:1218)NessusCentOS Local Security Checks
critical
84563Ubuntu 12.04 LTS / 14.04 LTS / 14.10 / 15.04 : php5 vulnerabilities (USN-2658-1)NessusUbuntu Local Security Checks
critical
84557openSUSE Security Update : php5 (openSUSE-2015-471)NessusSuSE Local Security Checks
critical
84394Scientific Linux Security Update : php on SL7.x x86_64 (20150623)NessusScientific Linux Local Security Checks
critical
84355RHEL 7 : php (RHSA-2015:1135)NessusRed Hat Local Security Checks
critical
84351Oracle Linux 7 : php (ELSA-2015-1135)NessusOracle Linux Local Security Checks
critical
84345CentOS 7 : php (CESA-2015:1135)NessusCentOS Local Security Checks
critical
8784PHP 5.4.x < 5.4.40 / 5.5.x < 5.5.24 / 5.6.x < 5.6.8 Multiple VulnerabilitiesNessus Network MonitorWeb Servers
critical
83035PHP 5.6.x < 5.6.8 Multiple VulnerabilitiesNessusCGI abuses
critical
83034PHP 5.5.x < 5.5.24 Multiple VulnerabilitiesNessusCGI abuses
critical
83033PHP 5.4.x < 5.4.40 Multiple VulnerabilitiesNessusCGI abuses
critical