CVE-2015-4496

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Multiple integer overflows in libstagefright in Mozilla Firefox before 38.0 allow remote attackers to execute arbitrary code via crafted sample metadata in an MPEG-4 video file, a related issue to CVE-2015-1538.

References

http://www.mozilla.org/security/announce/2015/mfsa2015-93.html

http://www.oracle.com/technetwork/topics/security/bulletinapr2016-2952098.html

https://bugzilla.mozilla.org/show_bug.cgi?id=1149605

https://hg.mozilla.org/mozilla-central/rev/87277085561a

Details

Source: MITRE

Published: 2015-08-16

Updated: 2016-11-15

Type: CWE-189

Risk Information

CVSS v2

Base Score: 9.3

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 8.6

Severity: HIGH

Vulnerable Software

Configuration 1

OR

cpe:2.3:o:oracle:solaris:11.3:*:*:*:*:*:*:*

Configuration 2

OR

cpe:2.3:a:mozilla:firefox:*:*:*:*:*:*:*:* versions up to 37.0.2 (inclusive)

Tenable Plugins

View all (8 total)

IDNameProductFamilySeverity
701255Mozilla Firefox ESR < 31.7 Multiple VulnerabilitiesNessus Network MonitorWeb Clients
critical
8865Mozilla Firefox < 38.0 Multiple VulnerabilitiesNessus Network MonitorWeb Clients
critical
83439Firefox < 38.0 Multiple VulnerabilitiesNessusWindows
critical
83437Firefox < 38.0 Multiple Vulnerabilities (Mac OS X)NessusMacOS X Local Security Checks
high
83409RHEL 5 / 6 / 7 : firefox (RHSA-2015:0988)NessusRed Hat Local Security Checks
high
83403Oracle Linux 5 / 6 / 7 : firefox (ELSA-2015-0988)NessusOracle Linux Local Security Checks
high
83389FreeBSD : mozilla -- multiple vulnerabilities (d9b43004-f5fd-4807-b1d7-dbf66455b244)NessusFreeBSD Local Security Checks
critical
83378CentOS 5 / 6 / 7 : firefox (CESA-2015:0988)NessusCentOS Local Security Checks
high