CVE-2015-3226

MEDIUM

Description

Cross-site scripting (XSS) vulnerability in json/encoding.rb in Active Support in Ruby on Rails 3.x and 4.1.x before 4.1.11 and 4.2.x before 4.2.2 allows remote attackers to inject arbitrary web script or HTML via a crafted Hash that is mishandled during JSON encoding.

References

http://openwall.com/lists/oss-security/2015/06/16/17

http://www.debian.org/security/2016/dsa-3464

http://www.securityfocus.com/bid/75231

http://www.securitytracker.com/id/1033755

https://groups.google.com/forum/message/raw?msg=rubyonrails-security/7VlB_pck3hU/3QZrGIaQW6cJ

Details

Source: MITRE

Published: 2015-07-26

Updated: 2019-08-08

Type: CWE-79

Risk Information

CVSS v2.0

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM