CVE-2015-2774

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Erlang/OTP before 18.0-rc1 does not properly check CBC padding bytes when terminating connections, which makes it easier for man-in-the-middle attackers to obtain cleartext data via a padding-oracle attack, a variant of CVE-2014-3566 (aka POODLE).

References

http://lists.opensuse.org/opensuse-updates/2016-02/msg00124.html

http://openwall.com/lists/oss-security/2015/03/27/6

http://openwall.com/lists/oss-security/2015/03/27/9

http://www.oracle.com/technetwork/topics/security/bulletinapr2015-2511959.html

http://www.securityfocus.com/bid/73398

https://usn.ubuntu.com/3571-1/

https://web.archive.org/web/20150905124006/http://www.erlang.org/news/85

https://www.imperialviolet.org/2014/12/08/poodleagain.html

Details

Source: MITRE

Published: 2016-04-07

Updated: 2018-10-30

Type: CWE-200

Risk Information

CVSS v2

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:P/I:N/A:N

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 5.9

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

Impact Score: 3.6

Exploitability Score: 2.2

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:erlang:otp:*:*:*:*:*:*:*:* versions up to 18.0 (inclusive)

Configuration 2

OR

cpe:2.3:o:oracle:solaris:11.2:*:*:*:*:*:*:*

Configuration 3

OR

cpe:2.3:o:opensuse:opensuse:13.2:*:*:*:*:*:*:*

Tenable Plugins

View all (5 total)

IDNameProductFamilySeverity
106838Ubuntu 14.04 LTS / 16.04 LTS / 17.10 : erlang vulnerabilities (USN-3571-1) (ROBOT)NessusUbuntu Local Security Checks
critical
92048Fedora 23 : erlang (2015-33583e5029)NessusFedora Local Security Checks
medium
88920openSUSE Security Update : erlang (openSUSE-2016-245)NessusSuSE Local Security Checks
medium
85472Fedora 21 : erlang-17.4-4.fc21 (2015-12970)NessusFedora Local Security Checks
medium
85470Fedora 22 : erlang-17.4-4.fc22 (2015-12923)NessusFedora Local Security Checks
medium