CVE-2015-2694

MEDIUM
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The kdcpreauth modules in MIT Kerberos 5 (aka krb5) 1.12.x and 1.13.x before 1.13.2 do not properly track whether a client's request has been validated, which allows remote attackers to bypass an intended preauthentication requirement by providing (1) zero bytes of data or (2) an arbitrary realm name, related to plugins/preauth/otp/main.c and plugins/preauth/pkinit/pkinit_srv.c.

References

http://krbdev.mit.edu/rt/Ticket/Display.html?id=8160

http://www.oracle.com/technetwork/topics/security/linuxbulletinoct2015-2719645.html

http://www.securityfocus.com/bid/74824

http://www.ubuntu.com/usn/USN-2810-1

https://github.com/krb5/krb5/commit/e3b5a5e5267818c97750b266df50b6a3d4649604

Details

Source: MITRE

Published: 2015-05-25

Updated: 2020-01-21

Type: CWE-264

Risk Information

CVSS v2

Base Score: 5.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:N

Impact Score: 4.9

Exploitability Score: 8.6

Severity: MEDIUM

Tenable Plugins

View all (10 total)

IDNameProductFamilySeverity
87560Scientific Linux Security Update : krb5 on SL7.x x86_64 (20151119)NessusScientific Linux Local Security Checks
medium
87350Amazon Linux AMI : krb5 (ALAS-2015-624)NessusAmazon Linux Local Security Checks
medium
87136CentOS 7 : krb5 (CESA-2015:2154)NessusCentOS Local Security Checks
medium
87026Oracle Linux 7 : krb5 (ELSA-2015-2154)NessusOracle Linux Local Security Checks
medium
86933RHEL 7 : krb5 (RHSA-2015:2154)NessusRed Hat Local Security Checks
medium
86872Ubuntu 12.04 LTS / 14.04 LTS / 15.04 / 15.10 : krb5 vulnerabilities (USN-2810-1)NessusUbuntu Local Security Checks
high
84914SUSE SLES12 Security Update : krb5 (SUSE-SU-2015:1276-1)NessusSuSE Local Security Checks
medium
84305Fedora 21 : krb5-1.12.2-17.fc21 (2015-7878)NessusFedora Local Security Checks
medium
83901FreeBSD : krb5 -- requires_preauth bypass in PKINIT-enabled KDC (406636fe-055d-11e5-aab1-d050996490d0)NessusFreeBSD Local Security Checks
medium
83340Fedora 22 : krb5-1.13.1-3.fc22 (2015-7866)NessusFedora Local Security Checks
medium