CVE-2015-2327

HIGH

Description

PCRE before 8.36 mishandles the /(((a\2)|(a*)\g<-1>))*/ pattern and related patterns with certain internal recursive back references, which allows remote attackers to cause a denial of service (segmentation fault) or possibly have unspecified other impact via a crafted regular expression, as demonstrated by a JavaScript RegExp object encountered by Konqueror.

References

http://rhn.redhat.com/errata/RHSA-2016-2750.html

http://vcs.pcre.org/pcre/code/trunk/ChangeLog?view=markup

http://www.fortiguard.com/advisory/FG-VD-15-010/

http://www.openwall.com/lists/oss-security/2015/11/29/1

http://www.securityfocus.com/bid/74924

https://bugs.exim.org/show_bug.cgi?id=1503

https://jira.mongodb.org/browse/SERVER-17252

Details

Source: MITRE

Published: 2015-12-02

Updated: 2018-01-05

Type: CWE-119

Risk Information

CVSS v2.0

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:pcre:perl_compatible_regular_expression_library:*:*:*:*:*:*:*:* versions up to 8.35 (inclusive)

Tenable Plugins

View all (6 total)

IDNameProductFamilySeverity
125102EulerOS Virtualization 3.0.1.0 : pcre (EulerOS-SA-2019-1558)NessusHuawei Local Security Checks
high
95915SUSE SLED12 / SLES12 Security Update : pcre (SUSE-SU-2016:3161-1)NessusSuSE Local Security Checks
high
95754openSUSE Security Update : pcre (openSUSE-2016-1448)NessusSuSE Local Security Checks
high
95534SUSE SLED12 / SLES12 Security Update : pcre (SUSE-SU-2016:2971-1)NessusSuSE Local Security Checks
high
92667F5 Networks BIG-IP : Multiple PCRE vulnerabilities (K20225390)NessusF5 Networks Local Security Checks
high
90306Ubuntu 12.04 LTS / 14.04 LTS / 15.10 : pcre3 vulnerabilities (USN-2943-1)NessusUbuntu Local Security Checks
high