CVE-2015-1351

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Use-after-free vulnerability in the _zend_shared_memdup function in zend_shared_alloc.c in the OPcache extension in PHP through 5.6.7 allows remote attackers to cause a denial of service or possibly have unspecified other impact via unknown vectors.

References

http://git.php.net/?p=php-src.git;a=commit;h=777c39f4042327eac4b63c7ee87dc1c7a09a3115

http://lists.apple.com/archives/security-announce/2015/Sep/msg00008.html

http://openwall.com/lists/oss-security/2015/01/24/9

http://rhn.redhat.com/errata/RHSA-2015-1053.html

http://rhn.redhat.com/errata/RHSA-2015-1066.html

http://www.mandriva.com/security/advisories?name=MDVSA-2015:079

http://www.oracle.com/technetwork/security-advisory/cpuoct2016-2881722.html

http://www.oracle.com/technetwork/topics/security/bulletinjul2015-2511963.html

http://www.oracle.com/technetwork/topics/security/linuxbulletinjan2016-2867209.html

http://www.securityfocus.com/bid/71929

https://bugs.php.net/bug.php?id=68677

https://security.gentoo.org/glsa/201606-10

https://support.apple.com/HT205267

Details

Source: MITRE

Published: 2015-03-30

Updated: 2019-12-27

Type: CWE-416

Risk Information

CVSS v2

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:oracle:secure_backup:*:*:*:*:*:*:*:* versions up to 12.1.0.1.0 (inclusive)

Configuration 2

OR

cpe:2.3:o:apple:mac_os_x:*:*:*:*:*:*:*:* versions up to 10.6.8 (inclusive)

Configuration 3

OR

cpe:2.3:a:php:php:*:*:*:*:*:*:*:* versions up to 5.6.7 (inclusive)

Configuration 4

OR

cpe:2.3:o:oracle:linux:6:*:*:*:*:*:*:*

cpe:2.3:o:oracle:linux:7:*:*:*:*:*:*:*

cpe:2.3:o:oracle:solaris:11.2:*:*:*:*:*:*:*

Tenable Plugins

View all (19 total)

IDNameProductFamilySeverity
126500SUSE SLES12 Security Update : php5 (SUSE-SU-2019:1746-1)NessusSuSE Local Security Checks
critical
98831PHP 5.6.x < 5.6.8 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
91704GLSA-201606-10 : PHP: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical
8982Mac OS X < 10.11 Multiple VulnerabilitiesNessus Network MonitorOperating System Detection
critical
86270Mac OS X < 10.11 Multiple Vulnerabilities (GHOST)NessusMacOS X Local Security Checks
critical
8784PHP 5.4.x < 5.4.40 / 5.5.x < 5.5.24 / 5.6.x < 5.6.8 Multiple VulnerabilitiesNessus Network MonitorWeb Servers
critical
83093Fedora 20 : php-5.5.24-1.fc20 (2015-6399)NessusFedora Local Security Checks
high
83080FreeBSD : Several vulnerabilities found in PHP (1e232a0c-eb57-11e4-b595-4061861086c1)NessusFreeBSD Local Security Checks
high
83044Fedora 21 : php-5.6.8-1.fc21 (2015-6407)NessusFedora Local Security Checks
high
83035PHP 5.6.x < 5.6.8 Multiple VulnerabilitiesNessusCGI abuses
critical
83034PHP 5.5.x < 5.5.24 Multiple VulnerabilitiesNessusCGI abuses
critical
83018Fedora 22 : php-5.6.8-1.fc22 (2015-6195)NessusFedora Local Security Checks
high
82923Slackware 14.0 / 14.1 / current : php (SSA:2015-111-10)NessusSlackware Local Security Checks
high
82858Amazon Linux AMI : php56 (ALAS-2015-511)NessusAmazon Linux Local Security Checks
high
82857Amazon Linux AMI : php55 (ALAS-2015-510)NessusAmazon Linux Local Security Checks
high
82333Mandriva Linux Security Advisory : php (MDVSA-2015:080)NessusMandriva Local Security Checks
high
82332Mandriva Linux Security Advisory : php (MDVSA-2015:079)NessusMandriva Local Security Checks
high
8909PHP 5.5.x < 5.5.21 / 5.6.x < 5.6.5 Multiple VulnerabilitiesNessus Network MonitorWeb Servers
high
81399Ubuntu 12.04 LTS / 14.04 LTS / 14.10 : php5 vulnerabilities (USN-2501-1)NessusUbuntu Local Security Checks
high