CVE-2015-1297

HIGH

Description

The WebRequest API implementation in extensions/browser/api/web_request/web_request_api.cc in Google Chrome before 45.0.2454.85 does not properly consider a request's source before accepting the request, which allows remote attackers to bypass intended access restrictions via a crafted (1) app or (2) extension.

References

http://googlechromereleases.blogspot.com/2015/09/stable-channel-update.html

http://lists.opensuse.org/opensuse-updates/2015-09/msg00029.html

http://lists.opensuse.org/opensuse-updates/2015-11/msg00013.html

http://rhn.redhat.com/errata/RHSA-2015-1712.html

http://www.debian.org/security/2015/dsa-3351

http://www.securitytracker.com/id/1033472

https://code.google.com/p/chromium/issues/detail?id=510802

https://codereview.chromium.org/1267183003/

https://security.gentoo.org/glsa/201603-09

Details

Source: MITRE

Published: 2015-09-03

Updated: 2016-12-22

Type: CWE-254

Risk Information

CVSS v2.0

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH