CVE-2015-0274

HIGH

Description

The XFS implementation in the Linux kernel before 3.15 improperly uses an old size value during remote attribute replacement, which allows local users to cause a denial of service (transaction overrun and data corruption) or possibly gain privileges by leveraging XFS filesystem access.

References

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=8275cdd0e7ac550dcce2b3ef6d2fb3b808c1ae59

http://rhn.redhat.com/errata/RHSA-2015-0290.html

http://rhn.redhat.com/errata/RHSA-2015-0694.html

http://www.securitytracker.com/id/1031853

http://www.ubuntu.com/usn/USN-2543-1

http://www.ubuntu.com/usn/USN-2544-1

https://bugzilla.redhat.com/show_bug.cgi?id=1195248

https://github.com/torvalds/linux/commit/8275cdd0e7ac550dcce2b3ef6d2fb3b808c1ae59

Details

Source: MITRE

Published: 2015-03-16

Updated: 2015-03-27

Type: CWE-19

Risk Information

CVSS v2.0

Base Score: 7.2

Vector: AV:L/AC:L/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 3.9

Severity: HIGH