CVE-2015-0250

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

XML external entity (XXE) vulnerability in the SVG to (1) PNG and (2) JPG conversion classes in Apache Batik 1.x before 1.8 allows remote attackers to read arbitrary files or cause a denial of service via a crafted SVG file.

References

http://advisories.mageia.org/MGASA-2015-0138.html

http://packetstormsecurity.com/files/130964/Apache-Batik-XXE-Injection.html

http://rhn.redhat.com/errata/RHSA-2016-0041.html

http://rhn.redhat.com/errata/RHSA-2016-0042.html

http://seclists.org/fulldisclosure/2015/Mar/142

http://www.debian.org/security/2015/dsa-3205

http://www.mandriva.com/security/advisories?name=MDVSA-2015:203

http://www.securitytracker.com/id/1032781

http://www.ubuntu.com/usn/USN-2548-1

http://www-01.ibm.com/support/docview.wss?uid=swg21963275

http://xmlgraphics.apache.org/security.html

Details

Source: MITRE

Published: 2015-03-24

Updated: 2017-11-04

Risk Information

CVSS v2

Base Score: 6.4

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:P

Impact Score: 4.9

Exploitability Score: 10

Severity: MEDIUM

Tenable Plugins

View all (8 total)

IDNameProductFamilySeverity
9716IBM WebSphere Application Server 8.5 < 8.5.5.6 Multiple Vulnerabilities (FREAK)Nessus Network MonitorWeb Servers
high
9713IBM WebSphere Application Server 8.0 < 8.0.0.11 Multiple Vulnerabilities (FREAK)Nessus Network MonitorWeb Servers
high
9700IBM WebSphere Application Server 7.0 < 7.0.0.39 Multiple Vulnerabilities (FREAK)Nessus Network MonitorWeb Servers
high
84639IBM WebSphere Application Server 7.0 < 7.0.0.39 (FP39) / 8.0 < 8.0.0.11 (FP11) / 8.5 < 8.5.5.6 (FP6) Multiple Vulnerabilities (Bar Mitzvah) (FREAK)NessusWeb Servers
high
82738Mandriva Linux Security Advisory : batik (MDVSA-2015:203)NessusMandriva Local Security Checks
medium
82302Debian DSA-3205-1 : batik - security updateNessusDebian Local Security Checks
medium
82299Debian DLA-182-1 : batik security updateNessusDebian Local Security Checks
medium
82267Ubuntu 12.04 LTS / 14.04 LTS / 14.10 : batik vulnerability (USN-2548-1)NessusUbuntu Local Security Checks
medium