CVE-2014-9709

MEDIUM
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The GetCode_ function in gd_gif_in.c in GD 2.1.1 and earlier, as used in PHP before 5.5.21 and 5.6.x before 5.6.5, allows remote attackers to cause a denial of service (buffer over-read and application crash) via a crafted GIF image that is improperly handled by the gdImageCreateFromGif function.

References

http://advisories.mageia.org/MGASA-2015-0040.html

http://lists.apple.com/archives/security-announce/2015/Sep/msg00008.html

http://lists.opensuse.org/opensuse-security-announce/2015-05/msg00005.html

http://lists.opensuse.org/opensuse-updates/2015-04/msg00002.html

http://marc.info/?l=bugtraq&m=143403519711434&w=2

http://php.net/ChangeLog-5.php

http://rhn.redhat.com/errata/RHSA-2015-1053.html

http://rhn.redhat.com/errata/RHSA-2015-1066.html

http://rhn.redhat.com/errata/RHSA-2015-1135.html

http://rhn.redhat.com/errata/RHSA-2015-1218.html

http://www.debian.org/security/2015/dsa-3215

http://www.mandriva.com/security/advisories?name=MDVSA-2015:153

http://www.oracle.com/technetwork/topics/security/bulletinapr2015-2511959.html

http://www.oracle.com/technetwork/topics/security/linuxbulletinjan2016-2867209.html

http://www.securityfocus.com/bid/73306

http://www.securitytracker.com/id/1033703

http://www.ubuntu.com/usn/USN-2987-1

https://bitbucket.org/libgd/gd-libgd/commits/47eb44b2e90ca88a08dca9f9a1aa9041e9587f43

https://bugs.php.net/bug.php?id=68601

https://bugzilla.redhat.com/show_bug.cgi?id=1188639

https://security.gentoo.org/glsa/201606-10

https://security.gentoo.org/glsa/201607-04

https://support.apple.com/HT205267

Details

Source: MITRE

Published: 2015-03-30

Updated: 2019-10-09

Type: CWE-119

Risk Information

CVSS v2

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

Tenable Plugins

View all (33 total)

IDNameProductFamilySeverity
124966EulerOS Virtualization 3.0.1.0 : gd (EulerOS-SA-2019-1463)NessusHuawei Local Security Checks
medium
98828PHP 5.6.x < 5.6.5 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
119964SUSE SLES12 Security Update : php5 (SUSE-SU-2015:0868-1)NessusSuSE Local Security Checks
high
93161SUSE SLES11 Security Update : php53 (SUSE-SU-2016:1638-1) (BACKRONYM)NessusSuSE Local Security Checks
critical
92348GLSA-201607-04 : GD: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical
91704GLSA-201606-10 : PHP: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical
91423Ubuntu 12.04 LTS / 14.04 LTS / 15.10 / 16.04 LTS : libgd2 vulnerabilities (USN-2987-1)NessusUbuntu Local Security Checks
critical
88813F5 Networks BIG-IP : PHP vulnerability (K17127)NessusF5 Networks Local Security Checks
medium
8982Mac OS X < 10.11 Multiple VulnerabilitiesNessus Network MonitorOperating System Detection
critical
86270Mac OS X < 10.11 Multiple Vulnerabilities (GHOST)NessusMacOS X Local Security Checks
critical
84661Scientific Linux Security Update : php on SL6.x i386/x86_64 (20150709)NessusScientific Linux Local Security Checks
critical
84660RHEL 6 : php (RHSA-2015:1218)NessusRed Hat Local Security Checks
critical
84659Oracle Linux 6 : php (ELSA-2015-1218)NessusOracle Linux Local Security Checks
critical
84648CentOS 6 : php (CESA-2015:1218)NessusCentOS Local Security Checks
critical
84394Scientific Linux Security Update : php on SL7.x x86_64 (20150623)NessusScientific Linux Local Security Checks
critical
84355RHEL 7 : php (RHSA-2015:1135)NessusRed Hat Local Security Checks
critical
84351Oracle Linux 7 : php (ELSA-2015-1135)NessusOracle Linux Local Security Checks
critical
84345CentOS 7 : php (CESA-2015:1135)NessusCentOS Local Security Checks
critical
8784PHP 5.4.x < 5.4.40 / 5.5.x < 5.5.24 / 5.6.x < 5.6.8 Multiple VulnerabilitiesNessus Network MonitorWeb Servers
critical
84082SUSE SLES11 Security Update : php53 (SUSE-SU-2015:1018-1)NessusSuSE Local Security Checks
high
83286SuSE 11.3 Security Update : gd (SAT Patch Number 10530)NessusSuSE Local Security Checks
medium
83080FreeBSD : Several vulnerabilities found in PHP (1e232a0c-eb57-11e4-b595-4061861086c1)NessusFreeBSD Local Security Checks
high
83033PHP 5.4.x < 5.4.40 Multiple VulnerabilitiesNessusCGI abuses
critical
82923Slackware 14.0 / 14.1 / current : php (SSA:2015-111-10)NessusSlackware Local Security Checks
high
82856Amazon Linux AMI : php54 (ALAS-2015-509)NessusAmazon Linux Local Security Checks
high
82646Debian DLA-189-1 : libgd2 security updateNessusDebian Local Security Checks
medium
82623Debian DSA-3215-1 : libgd2 - security updateNessusDebian Local Security Checks
medium
82516openSUSE Security Update : php5 (openSUSE-2015-282)NessusSuSE Local Security Checks
high
82487openSUSE Security Update : gd (openSUSE-2015-280)NessusSuSE Local Security Checks
medium
82406Mandriva Linux Security Advisory : libgd (MDVSA-2015:153)NessusMandriva Local Security Checks
medium
8909PHP 5.5.x < 5.5.21 / 5.6.x < 5.6.5 Multiple VulnerabilitiesNessus Network MonitorWeb Servers
high
81082PHP 5.6.x < 5.6.5 Multiple VulnerabilitiesNessusCGI abuses
critical
81081PHP 5.5.x < 5.5.21 Multiple VulnerabilitiesNessusCGI abuses
critical