CVE-2014-9065

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

common/spinlock.c in Xen 4.4.x and earlier does not properly handle read and write locks, which allows local x86 guest users to cause a denial of service (write denial or NMI watchdog timeout and host crash) via a large number of read requests, a different vulnerability to CVE-2014-9066.

References

http://lists.opensuse.org/opensuse-security-announce/2015-02/msg00005.html

http://lists.opensuse.org/opensuse-security-announce/2015-02/msg00010.html

http://www.openwall.com/lists/oss-security/2014/12/08/4

http://www.securityfocus.com/bid/71544

http://xenbits.xen.org/xsa/advisory-114.html

https://security.gentoo.org/glsa/201504-04

Details

Source: MITRE

Published: 2014-12-09

Updated: 2018-10-30

Type: CWE-17

Risk Information

CVSS v2

Base Score: 4.4

Vector: AV:L/AC:M/Au:S/C:N/I:N/A:C

Impact Score: 6.9

Exploitability Score: 2.7

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:o:xen:xen:*:*:*:*:*:*:*:* versions up to 4.4.1 (inclusive)

Configuration 2

OR

cpe:2.3:o:opensuse:opensuse:13.1:*:*:*:*:*:*:*

cpe:2.3:o:opensuse:opensuse:13.2:*:*:*:*:*:*:*

Tenable Plugins

View all (8 total)

IDNameProductFamilySeverity
140019OracleVM 3.4 : xen (OVMSA-2020-0039) (Bunker Buster) (Foreshadow) (MDSUM/RIDL) (MFBDS/RIDL/ZombieLoad) (MLPDS/RIDL) (MSBDS/Fallout) (Meltdown) (POODLE) (Spectre)NessusOracleVM Local Security Checks
critical
111992OracleVM 3.4 : xen (OVMSA-2018-0248) (Bunker Buster) (Foreshadow) (Meltdown) (POODLE) (Spectre)NessusOracleVM Local Security Checks
critical
83717SUSE SLES10 Security Update : Xen (SUSE-SU-2015:0744-1)NessusSuSE Local Security Checks
high
83707SUSE SLED12 / SLES12 Security Update : Xen (SUSE-SU-2015:0613-1)NessusSuSE Local Security Checks
high
82734GLSA-201504-04 : Xen: Multiple vulnerabilitiesNessusGentoo Local Security Checks
high
81305openSUSE Security Update : xen (openSUSE-2015-129)NessusSuSE Local Security Checks
high
81239openSUSE Security Update : xen (openSUSE-2015-113)NessusSuSE Local Security Checks
high
80928OracleVM 3.3 : xen (OVMSA-2015-0004)NessusOracleVM Local Security Checks
medium