CVE-2014-8626

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Stack-based buffer overflow in the date_from_ISO8601 function in ext/xmlrpc/libxmlrpc/xmlrpc.c in PHP before 5.2.7 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code by including a timezone field in a date, leading to improper XML-RPC encoding.

References

http://git.php.net/?p=php-src.git;a=commit;h=c818d0d01341907fee82bdb81cab07b7d93bb9db

http://openwall.com/lists/oss-security/2014/11/06/3

http://php.net/ChangeLog-5.php

http://rhn.redhat.com/errata/RHSA-2014-1824.html

http://rhn.redhat.com/errata/RHSA-2014-1825.html

http://www.securityfocus.com/bid/70928

https://bugs.php.net/bug.php?id=45226

https://bugzilla.redhat.com/show_bug.cgi?id=1155607

Details

Source: MITRE

Published: 2014-11-23

Updated: 2015-04-30

Type: CWE-119

Risk Information

CVSS v2

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

Tenable Plugins

View all (6 total)

IDNameProductFamilySeverity
4779PHP 5.x < 5.2.7 Multiple VulnerabilitiesNessus Network MonitorWeb Servers
high
79082Scientific Linux Security Update : php on SL5.x i386/x86_64 (20141106)NessusScientific Linux Local Security Checks
high
78909RHEL 5 : php (RHSA-2014:1824)NessusRed Hat Local Security Checks
high
78908Oracle Linux 5 : php (ELSA-2014-1824)NessusOracle Linux Local Security Checks
high
78895CentOS 5 : php (CESA-2014:1824)NessusCentOS Local Security Checks
high
35043PHP 5 < 5.2.7 Multiple VulnerabilitiesNessusCGI abuses
high