CVE-2014-7900

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Use-after-free vulnerability in the CPDF_Parser::IsLinearizedFile function in fpdfapi/fpdf_parser/fpdf_parser_parser.cpp in PDFium, as used in Google Chrome before 39.0.2171.65, allows remote attackers to cause a denial of service or possibly have unspecified other impact via a crafted PDF document.

References

http://googlechromereleases.blogspot.com/2014/11/stable-channel-update_18.html

http://www.securityfocus.com/bid/71163

http://www.securitytracker.com/id/1031241

https://code.google.com/p/chromium/issues/detail?id=406868

https://exchange.xforce.ibmcloud.com/vulnerabilities/98788

https://pdfium.googlesource.com/pdfium/+/1b04ea3b0fbae3be3ae6b3824c5e0dadc0e73d44

Details

Source: MITRE

Published: 2014-11-19

Updated: 2017-09-08

Type: CWE-399

Risk Information

CVSS v2

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:google:chrome:*:*:*:*:*:*:*:* versions up to 39.0.2171.45 (inclusive)

Tenable Plugins

View all (6 total)

IDNameProductFamilySeverity
8580Google Chrome < 39.0.2171.65 Multiple VulnerabilitiesNessus Network MonitorWeb Clients
high
79997openSUSE Security Update : chromium (openSUSE-SU-2014:1626-1)NessusSuSE Local Security Checks
critical
79966GLSA-201412-13 : Chromium: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical
79337Google Chrome < 39.0.2171.65 Multiple Vulnerabilities (Mac OS X)NessusMacOS X Local Security Checks
critical
79336Google Chrome < 39.0.2171.65 Multiple VulnerabilitiesNessusWindows
critical
79320FreeBSD : chromium -- multiple vulnerabilities (d395e44f-6f4f-11e4-a444-00262d5ed8ee)NessusFreeBSD Local Security Checks
critical