CVE-2014-5459

low
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The PEAR_REST class in REST.php in PEAR in PHP through 5.6.0 allows local users to write to arbitrary files via a symlink attack on a (1) rest.cachefile or (2) rest.cacheid file in /tmp/pear/cache/, related to the retrieveCacheFirst and useLocalCache functions.

References

http://lists.opensuse.org/opensuse-updates/2014-09/msg00024.html

http://lists.opensuse.org/opensuse-updates/2014-09/msg00055.html

http://www.openwall.com/lists/oss-security/2014/08/27/3

http://www.oracle.com/technetwork/topics/security/bulletinjan2015-2370101.html

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=759282

Details

Source: MITRE

Published: 2014-09-27

Updated: 2021-03-29

Type: CWE-59

Risk Information

CVSS v2

Base Score: 3.6

Vector: AV:L/AC:L/Au:N/C:N/I:P/A:P

Impact Score: 4.9

Exploitability Score: 3.9

Severity: LOW

Tenable Plugins

View all (3 total)

IDNameProductFamilySeverity
93161SUSE SLES11 Security Update : php53 (SUSE-SU-2016:1638-1) (BACKRONYM)NessusSuSE Local Security Checks
critical
77742SuSE 11.3 Security Update : php53 (SAT Patch Number 9718)NessusSuSE Local Security Checks
medium
77720openSUSE Security Update : php5 (openSUSE-SU-2014:1133-1)NessusSuSE Local Security Checks
medium