CVE-2014-5146

MEDIUM

Description

Certain MMU virtualization operations in Xen 4.2.x through 4.4.x before the xsa97-hap patch, when using Hardware Assisted Paging (HAP), are not preemptible, which allows local HVM guest to cause a denial of service (vcpu consumption) by invoking these operations, which process every page assigned to a guest, a different vulnerability than CVE-2014-5149.

References

http://lists.fedoraproject.org/pipermail/package-announce/2014-August/136980.html

http://lists.fedoraproject.org/pipermail/package-announce/2014-August/136981.html

http://lists.opensuse.org/opensuse-security-announce/2015-02/msg00005.html

http://lists.opensuse.org/opensuse-security-announce/2015-02/msg00010.html

http://www.securityfocus.com/bid/69198

http://www.securitytracker.com/id/1030723

http://xenbits.xen.org/xsa/advisory-97.html

https://exchange.xforce.ibmcloud.com/vulnerabilities/95234

https://security.gentoo.org/glsa/201504-04

Details

Source: MITRE

Published: 2014-08-22

Updated: 2018-10-30

Type: CWE-399

Risk Information

CVSS v2.0

Base Score: 4.7

Vector: AV:L/AC:M/Au:N/C:N/I:N/A:C

Impact Score: 6.9

Exploitability Score: 3.4

Severity: MEDIUM