CVE-2014-5030

low
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

CUPS before 2.0 allows local users to read arbitrary files via a symlink attack on (1) index.html, (2) index.class, (3) index.pl, (4) index.php, (5) index.pyc, or (6) index.py.

References

http://advisories.mageia.org/MGASA-2014-0313.html

http://rhn.redhat.com/errata/RHSA-2014-1388.html

http://secunia.com/advisories/60509

http://secunia.com/advisories/60787

http://www.debian.org/security/2014/dsa-2990

http://www.mandriva.com/security/advisories?name=MDVSA-2015:108

http://www.openwall.com/lists/oss-security/2014/07/22/13

http://www.openwall.com/lists/oss-security/2014/07/22/2

http://www.ubuntu.com/usn/USN-2341-1

https://cups.org/str.php?L4455

Details

Source: MITRE

Published: 2014-07-29

Updated: 2017-01-07

Type: CWE-59

Risk Information

CVSS v2

Base Score: 1.9

Vector: AV:L/AC:M/Au:N/C:P/I:N/A:N

Impact Score: 2.9

Exploitability Score: 3.4

Severity: LOW

Tenable Plugins

View all (15 total)

IDNameProductFamilySeverity
124935EulerOS Virtualization 3.0.1.0 : cups (EulerOS-SA-2019-1432)NessusHuawei Local Security Checks
high
82361Mandriva Linux Security Advisory : cups (MDVSA-2015:108)NessusMandriva Local Security Checks
medium
82170Debian DLA-22-1 : cups security updateNessusDebian Local Security Checks
medium
79550OracleVM 3.3 : cups (OVMSA-2014-0035)NessusOracleVM Local Security Checks
high
79177CentOS 6 : cups (CESA-2014:1388)NessusCentOS Local Security Checks
medium
78842Scientific Linux Security Update : cups on SL6.x i386/x86_64 (20141014)NessusScientific Linux Local Security Checks
medium
78781Amazon Linux AMI : cups (ALAS-2014-438)NessusAmazon Linux Local Security Checks
medium
78522Oracle Linux 6 : cups (ELSA-2014-1388)NessusOracle Linux Local Security Checks
medium
78405RHEL 6 : cups (RHSA-2014:1388)NessusRed Hat Local Security Checks
medium
77569Ubuntu 10.04 LTS / 12.04 LTS / 14.04 LTS : cups vulnerabilities (USN-2341-1)NessusUbuntu Local Security Checks
medium
77217SuSE 11.3 Security Update : CUPS (SAT Patch Number 9561)NessusSuSE Local Security Checks
medium
77149CUPS 1.7.x < 1.7.5 'get_file' Function Symlink Handling Info DisclosureNessusMisc.
medium
77039Mandriva Linux Security Advisory : cups (MDVSA-2014:151)NessusMandriva Local Security Checks
medium
76921Fedora 20 : cups-1.7.4-3.fc20 (2014-8752)NessusFedora Local Security Checks
medium
76857Debian DSA-2990-1 : cups - security updateNessusDebian Local Security Checks
medium