CVE-2014-3464

MEDIUM

Description

The EJB invocation handler implementation in Red Hat JBossWS, as used in JBoss Enterprise Application Platform (EAP) 6.2.0 and 6.3.0, does not properly enforce the method level restrictions for outbound messages, which allows remote authenticated users to access otherwise restricted JAX-WS handlers by leveraging permissions to the EJB class. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-2133.

References

http://rhn.redhat.com/errata/RHSA-2014-1019.html

http://rhn.redhat.com/errata/RHSA-2014-1020.html

http://rhn.redhat.com/errata/RHSA-2014-1021.html

https://bugzilla.redhat.com/show_bug.cgi?id=1102317

https://exchange.xforce.ibmcloud.com/vulnerabilities/95409

Details

Source: MITRE

Published: 2014-08-19

Updated: 2017-08-29

Type: CWE-264

Risk Information

CVSS v2.0

Base Score: 5.5

Vector: AV:N/AC:L/Au:S/C:P/I:P/A:N

Impact Score: 4.9

Exploitability Score: 8

Severity: MEDIUM

Tenable Plugins

View all (2 total)

IDNameProductFamilySeverity
77079RHEL 6 : JBoss EAP (RHSA-2014:1020)NessusRed Hat Local Security Checks
medium
77078RHEL 5 : JBoss EAP (RHSA-2014:1019)NessusRed Hat Local Security Checks
medium