CVE-2014-1895

medium

Description

Off-by-one error in the flask_security_avc_cachestats function in xsm/flask/flask_op.c in Xen 4.2.x and 4.3.x, when the maximum number of physical CPUs are in use, allows local users to cause a denial of service (host crash) or obtain sensitive information from hypervisor memory by leveraging a FLASK_AVC_CACHESTAT hypercall, which triggers a buffer over-read.

References

http://lists.opensuse.org/opensuse-security-announce/2014-03/msg00011.html

http://security.gentoo.org/glsa/glsa-201407-03.xml

http://www.openwall.com/lists/oss-security/2014/02/07/12

http://www.openwall.com/lists/oss-security/2014/02/10/6

http://xenbits.xen.org/xsa/advisory-85.html

Details

Source: MITRE

Published: 2014-04-01

Updated: 2017-01-07

Type: CWE-189

Risk Information

CVSS v2

Base Score: 5.8

Vector: AV:A/AC:M/Au:S/C:P/I:N/A:C

Impact Score: 7.8

Exploitability Score: 4.4

Severity: MEDIUM