CVE-2014-1893

medium

Description

Multiple integer overflows in the (1) FLASK_GETBOOL and (2) FLASK_SETBOOL suboperations in the flask hypercall in Xen 4.1.x, 3.3.x, 3.2.x, and earlier, when XSM is enabled, allow local users to cause a denial of service (processor fault) via unspecified vectors, a different vulnerability than CVE-2014-1891, CVE-2014-1892, and CVE-2014-1894.

References

http://lists.opensuse.org/opensuse-security-announce/2014-03/msg00010.html

http://lists.opensuse.org/opensuse-security-announce/2014-03/msg00011.html

http://lists.opensuse.org/opensuse-security-announce/2014-03/msg00021.html

http://security.gentoo.org/glsa/glsa-201407-03.xml

http://www.openwall.com/lists/oss-security/2014/02/07/12

http://www.openwall.com/lists/oss-security/2014/02/07/4

http://www.openwall.com/lists/oss-security/2014/02/10/8

http://xenbits.xen.org/xsa/advisory-84.html

Details

Source: MITRE

Published: 2014-04-01

Updated: 2017-01-07

Type: CWE-189

Risk Information

CVSS v2

Base Score: 5.2

Vector: AV:A/AC:M/Au:S/C:N/I:N/A:C

Impact Score: 6.9

Exploitability Score: 4.4

Severity: MEDIUM