CVE-2014-0188

HIGH

Description

The openshift-origin-broker in Red Hat OpenShift Enterprise 2.0.5, 1.2.7, and earlier does not properly handle authentication requests from the remote-user auth plugin, which allows remote attackers to bypass authentication and impersonate arbitrary users via the X-Remote-User header in a request to a passthrough trigger.

References

http://rhn.redhat.com/errata/RHSA-2014-0422.html

http://rhn.redhat.com/errata/RHSA-2014-0423.html

https://bugzilla.redhat.com/show_bug.cgi?id=1090120

Details

Source: MITRE

Published: 2014-04-24

Modified: 2018-12-11

Type: CWE-287

Risk Information

CVSS v2.0

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH